Signed APK get errors while debug API doesn't


#1

After I sign API with jarsigner and then zipalign the API, $http.post are not working.

$http.post() method is returning error in signed API while in other, it works fine.

While I sign the APK, I get a warning message which says:

"Warning no -tsa or -tsacert provided … "


#2

Hi @degroundshaker,

Instead of running jarsigner and zipalign manually, can you try the following instructions?:

This will allow cordova build android --release to use your keystore and do the jarsigning and zipaligning for you. I found that I ran into several issues when doing it all manually.

Let me know if that works for you.

Regards,


#3

HI Nic,

Thank you for support.

Problem was with my Self Signed SSL which is now fixed.

Debug APK exclude SSL exception i believe, thats why it dint give me any error but a signed one did.


#4

And for generating .keystore file I got a warning regarding -tsa. Which have to do with the expiry date,I dint get this bit in your blog,so if u mention it somewhere with detail or get me a link, it would be great.


#5

The validity attribute determines the expiration date of your keystore. The value goes by days which is why they recommend 10000 as the length.

Does that answer your question?


#6

I am facing the same problem. Can you explain in detail how you fixed it please ?


#7

I know its too late to reply, but try checking out if you are making a call to http:// or https:// url’s.
This was the case with me!

I had to change my https:// URLS to http:// since I had no SSL installed on my server, hence, my calls were not working.

Rest of it, was solved by answers of Nic above.