Running ionic build (or run) android get build error

in the capacitor-cordova-android-plugins

I see this

targetSdkVersion targetSdkVersion  = project.hasProperty('targetSdkVersion') ? rootProject.ext.targetSdkVersion : 31

the correct syntax is

targetSdkVersion project.hasProperty('targetSdkVersion') ? rootProject.ext.targetSdkVersion : 31

I see this in ./node_modules/@capacitor/cli/assets/capacitor-cordova-android-plugins/build.gradle

which is in the capacitor/cli “name”: “@capacitor/cli”,
“version”: “2.4.2”,

I am assuming that now my project config is way downlevel , package.json

"dependencies": {
    "@capacitor/android": "^2.4.2",
    "@capacitor/core": "^2.4.2",
    "@capacitor/ios": "^2.4.2",
    "@ionic-native/network-interface": "^4.20.0",
    "@ionic/core": "^6.3.2",
    "@ionic/vue": "^6.3.2",
    "@ionic/vue-router": "^6.3.2",
    "@types/vue2-hammer": "^2.1.2",
    "axios": "^0.21.0",
    "capacitor-udp": "^0.2.0",
    "cordova-chrome-sockets-tcp": "^1.4.0",
    "cordova-plugin-chrome-apps-common": "^1.0.7",
    "cordova-plugin-chrome-apps-iossocketscommon": "^1.0.2",
    "cordova-plugin-chrome-apps-sockets-tcp": "^1.3.7",
    "cordova-plugin-chrome-apps-sockets-tcpserver": "^1.2.4",
    "cordova-plugin-networkinterface": "^2.0.0",
    "core-js": "^3.6.5",
    "hammerjs": "^2.0.8",
    "jetifier": "^1.6.6",
    "vue": "^3.2.41",
    "vue-i18n": "^9.0.0-beta.6",
    "vue-router": "^4.1.5",
    "vue2-hammer": "^2.1.2"
  },
  "devDependencies": {
    "@capacitor/cli": "^2.4.2",
    "@types/jest": "^24.0.19",
    "@typescript-eslint/eslint-plugin": "^2.33.0",
    "@typescript-eslint/parser": "^2.33.0",
    "@vue/cli-plugin-babel": "~5.0.8",
    "@vue/cli-plugin-e2e-cypress": "~5.0.8",
    "@vue/cli-plugin-eslint": "~5.0.8",
    "@vue/cli-plugin-router": "~5.0.8",
    "@vue/cli-plugin-typescript": "~5.0.8",
    "@vue/cli-plugin-unit-jest": "~5.0.8",
    "@vue/cli-service": "~5.0.8",
    "@vue/compiler-sfc": "^3.0.0-0",
    "@vue/eslint-config-typescript": "^5.0.2",
    "@vue/test-utils": "^2.0.0-0",
    "cypress": "^9.7.0",
    "eslint": "^7.5.0",
    "eslint-plugin-vue": "^7.0.0-0",
    "jest": "^27.1.0",
    "ts-jest": "^27.0.4",
    "typescript": "~4.5.5",
    "vue-jest": "^5.0.0-0"

short of starting over how to I get this project working again… (code changes I understand)

starting over gets rid of all the build errors