RC3 Update fail


#1

Just went through the update procedures for RC3 on an existing app and having trouble.
I’m on OSX 10.11.6

npm install -g ionic
ionic -v reports 2.1.12

In the project folder npm install ionic-angular@latest --save
then npm install @ionic/app-scripts@latest --save-dev
One of them threw npm errors on zones so I updated package.json, wiped the node_module, npm install, no errors
** I copied the scripts attribute from a new RC3 app just in case
"scripts": {
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
"@angular/common": “2.1.1”,
"@angular/compiler": “2.1.1”,
"@angular/compiler-cli": “2.1.1”,
"@angular/core": “2.1.1”,
"@angular/forms": “2.1.1”,
"@angular/http": “2.1.1”,
"@angular/platform-browser": “2.1.1”,
"@angular/platform-browser-dynamic": “2.1.1”,
"@angular/platform-server": “2.1.1”,
"@ionic/storage": “1.1.6”,
“ionic-angular”: “2.0.0-rc.3”,
“ionic-native”: “2.2.6”,
“ionicons”: “3.0.0”,
“rxjs”: “5.0.0-beta.12”,
“zone.js”: “0.6.26”,
“lodash”: “^4.16.6”,
“moment”: “^2.15.2”,
“pouchdb”: “^6.0.7”
},
“devDependencies”: {
"@ionic/app-scripts": “0.0.46”,
“typescript”: “2.0.6”
},

Running ionic serve on with app-scripts.0.0.46 errors, complaining about copying from node_modules/ionic-angular/fonts to www/assets/fonts but proceeds without any other errors, however, chrome debugger reports a 404 on build/main.js and that file does not exist in the file system.

I stepped app-scripts back to .45 and I don’t get the font copy issue but still get the 404 on main.js.

I did verify that I can ionic start and app and have it run.

In both existing and new apps ionic serve won’t let me type commands to her anymore, for instance q for quit… I have to control-c out of it.

I think my next steps are to ionic start a new app, copy my existing pages/providers/app files in and see if I get the same thing but I wonder if anybody else is seeing similar issues on rc3

Thanks


#2

On a mac as well, with similar base package.json configs. I do get the font copy error, although if I delete the www folder it goes away on first build. Everything else seems to be working for me with an existing project, including cli commands. I had some additional initial javascript errors that went away once I deleted node_modules and ran npm install.


#3

Just to confirm it seems to be resolved by reverting to "@ionic/app-scripts": "0.0.45" in package.json and doing npm install


#4

reverting only fixed the copy fonts issue. removing everything in www also fixes this issue as intelinc suggests. I still have to ctrl-c out of ionic serve and I’m still not getting main.js to build.
still digging through this to see if I can figure it out before I do the ionic start, then copy upgrade route.


#5

I have this figured out for the most part and it’s a build error that isn’t reported. In order to figure it out I ionic started a new app and very slowly moved pieces in until I found the error. I had a faulty export statement. for example export * from model1/model1 where the folder or file model1 didn’t exist. I’m not sure how this could work on the old version but it was, I swear ;-). My editor of choice wasn’t that helpful either, only reporting the issue when I opened the faulty file. [Atom in cape-and-tights mode]

ionic start uses version .45 of ionic-app-scripts and that does not show a copy fonts error like version.46. I’m sticking with that for now.

I still have to ctrl-c to get out of ionic-serve but I can live with that.

I’m not crazy about build errors possibly not showing up and only manifesting in a 404 on main.js

This is feels environmental so I think I’ll see what happens on windows with the same code. For now I’m working and not totally trusting what I see.