# RC Upgrade - NG2 Chart Unmet Peer Dependency

**URL:** <https://forum.ionicframework.com/t/rc-upgrade-ng2-chart-unmet-peer-dependency/65287>\
**Category:** ionic-v3\
**Created:** [October 1, 2016, 1:00am UTC](https://forum.ionicframework.com/t/rc-upgrade-ng2-chart-unmet-peer-dependency/65287 "2016-10-01T01:00:47Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![keeper3000](https://sea1.discourse-cdn.com/ionicframework/user_avatar/forum.ionicframework.com/keeper3000/32/101609_2.png) [@keeper3000](https://forum.ionicframework.com/u/keeper3000)\
**Post date:** [October 1, 2016, 1:00am UTC](https://forum.ionicframework.com/t/rc-upgrade-ng2-chart-unmet-peer-dependency/65287/1 "2016-10-01T01:00:47Z")

</div>

I’m having a tough time with the upgrade to RC.0 and am hoping you can help. Basically I’m getting UNMET PEER DEPENDENCY and ultimately cannot start the app.

$ npm install  
ionic-hello-world@ C:\projects\slo  
±- UNMET PEER DEPENDENCY @angular/common@2.0.1  
±- UNMET PEER DEPENDENCY @angular/compiler@2.0.1  
±- UNMET PEER DEPENDENCY @angular/core@2.0.1  
±- UNMET PEER DEPENDENCY @angular/forms@2.0.1  
±- @angular/router@3.0.1  
`-- @angular/upgrade@2.0.1

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node\_modules\chokidar\node\_modules\fsevents):  
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})  
npm WARN ng2-charts@1.3.0 requires a peer of @angular/core@2.0.0 but none was installed.  
npm WARN ng2-charts@1.3.0 requires a peer of @angular/compiler@2.0.0 but none was installed.  
npm WARN ng2-charts@1.3.0 requires a peer of @angular/common@2.0.0 but none was installed.  
npm WARN ng2-charts@1.3.0 requires a peer of @angular/forms@2.0.0 but none was installed.

This is my dependencies block of my package.json:  
“dependencies”: {  
"@angular/common": “~2.0.1”,  
"@angular/compiler": “~2.0.1”,  
"@angular/core": “~2.0.1”,  
"@angular/forms": “~2.0.1”,  
"@angular/http": “~2.0.1”,  
"@angular/platform-browser": “~2.0.1”,  
"@angular/platform-browser-dynamic": “~2.0.1”,  
"@angular/router": “~3.0.1”,  
"@angular/upgrade": “~2.0.1”,  
"@ionic/storage": “1.0.3”,  
“chart.js”: “^2.3.0”,  
“ionic-angular”: “^2.0.0-rc.0”,  
“ionic-native”: “^2.0.3”,  
“ionicons”: “^3.0.0”,  
“ng2-charts”: “^1.3.0”  
},

Any guidance is greatly appreciated! I’ve also tried changing the angular 2 versions to 2.0.0 and get the same error.
