RC.0 doesn't recognize Promise

Hi guys,

I followed steps to upgrade to RC.0 from beta.11 (create fresh new myApp then copy&modify follow each step). Now I’m facing problem with Promise isn’t recognized.

Please guide if you have experience / knowledge on this to me, as I need this development back to usual progress soon.
Thanks much!

I had the same error in Webstorm, but actually only Webstorm didn’t recognize the promises.
When I was running (ionic serve) my app this was ok.

To tell Webstorm to find the promise I had to activate ECMAScript 6 and load typescript 2 (not 1.8)

1 Like

Thanks reedrichards, I resolved it by installing again typescript to version > 2 (2.0.3), it doesn’t notify more. But other headaches in migration to RC.0 happens (nothing works) :smile:

1 Like

I installed @types/es6-promise to resolve errors, then I got error TS2300: Duplicate identifier 'Promise'. Activating ECMAScript 6 worked, no errors now :thumbsup: Webstorm is awesome but these silly issues.

1 Like

Hi everyone, I have the same problem! What can I do to solve this ? help please !

Error: node_modules/@types/es6-promise/index.d.ts(11,15): error TS2300: Duplicate identifier ‘Promise’.

Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-rc.0
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
Node Version: v6.7.0

Get rid of this module.

rapropos, this do not help.