Project Package build failed on ionic-Creator


#1

Hello everybody

My Project package build failed . Has anyone a notion what to do?

ANDROID_HOME=/usr/local/src/android-sdk-linux JAVA_HOME=/usr/lib/jvm/java-8-oracle :preBuild UP-TO-DATE :preDebugBuild UP-TO-DATE :checkDebugManifest :CordovaLib:preBuild UP-TO-DATE :CordovaLib:preDebugBuild UP-TO-DATE :CordovaLib:compileDebugNdk UP-TO-DATE :CordovaLib:compileLint :CordovaLib:copyDebugLint UP-TO-DATE :CordovaLib:mergeDebugProguardFiles :CordovaLib:packageDebugRenderscript UP-TO-DATE :CordovaLib:checkDebugManifest :CordovaLib:prepareDebugDependencies :CordovaLib:compileDebugRenderscript :CordovaLib:generateDebugResValues :CordovaLib:generateDebugResources :CordovaLib:packageDebugResources :CordovaLib:compileDebugAidl :CordovaLib:generateDebugBuildConfig :CordovaLib:generateDebugAssets UP-TO-DATE :CordovaLib:mergeDebugAssets :CordovaLib:processDebugManifest :CordovaLib:processDebugResources :CordovaLib:generateDebugSources :CordovaLib:compileDebugJavaWithJavacNote: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. :CordovaLib:processDebugJavaRes UP-TO-DATE :CordovaLib:transformResourcesWithMergeJavaResForDebug :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug :CordovaLib:mergeDebugJniLibFolders :CordovaLib:transformNative_libsWithMergeJniLibsForDebug :CordovaLib:transformNative_libsWithSyncJniLibsForDebug :CordovaLib:bundleDebug :prepareAndroidCordovaLibUnspecifiedDebugLibrary :prepareDebugDependencies :compileDebugAidl :compileDebugRenderscript :generateDebugBuildConfig :generateDebugAssets UP-TO-DATE :mergeDebugAssets :generateDebugResValues :generateDebugResources :mergeDebugResources :processDebugManifest :processDebugResources FAILED FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ‘:processDebugResources’. > com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process ‘command ‘/usr/local/src/android-sdk-linux/build-tools/24.0.2/aapt’’ finished with non-zero exit value 1 * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED Total time: 4.019 secs Error: Error code 1 for command: /home/package/workspace/creator-bb54ccb6ee0a-14/cordova/platforms/android/gradlew with args: cdvBuildDebug,-b,/home/package/workspace/creator-bb54ccb6ee0a-14/cordova/platforms/android/build.gradle,-Dorg.gradle.daemon=true,-Pandroid.useDeprecatedNdk=true

many thanks for the help
regards beat


#2

I got the same error on one of my apps when packaging android, iOS was fine and my other apps are packaging both.

Only found this last night so haven’t properly looked into it yet, will let you know if I figure it out and will watch your post if figure it out before me.


#3

The response from the support team helped me.
The method: Clone the project and delete a page. Deploy a bulid an check the mailbox. Repeat until successful.
In my project caused the images in the slider problems.


#4

Thanks, I found the page with the issue and removed it, so the app publishes now.

Like yours it was a page where I had slider embedded, pages with full screen sliders worked fine tho.