--prod --release causes application to not correctly display information

#1

Hey folks,

So I have my application almost ready for App store release, I decided to release a beta program for it but when I started to build it with --prod and --release flags things started to get weird. Firstly there was a white screen after splash and nothing more, turned out it was wrong typescript version, problem solved. But right now, I have another problem, let me present you with an example.
item-detail.html

<button ion-button large block outline icon-end clear="true" color="dark" (click)="unfold($event)" id="Second" *ngIf="hasProperty('unfold_title2')">
      <span class="button-text" [ngStyle]="{'font-size': font_size}" innerHTML="{{item.unfold_title2}}"></span>
      <ion-icon [name]="isUnfolded.Second? 'arrow-dropup-circle':'arrow-dropdown-circle'"></ion-icon>
    </button>

focus on the button please, because it is not being correctly displayed. And yes, the item has the property of ‘unfold_title2’, triple checked.

my ionic info output:

Ionic:

   ionic (Ionic CLI)  : 4.10.3 (C:\Users\user\AppData\Roaming\npm\node_modules\ionic)
   Ionic Framework    : ionic-angular 3.9.4
   @ionic/app-scripts : 3.2.1

Cordova:

   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : android 7.1.4, browser 5.0.4, ios 4.5.5
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 2.2.5, (and 13 other plugins)

System:

   Android SDK Tools : 26.1.1 (C:\Users\user\AppData\Local\Android\Sdk)
   NodeJS            : v10.14.1 (C:\Program Files\nodejs\node.exe)
   npm               : 6.4.1
   OS                : Windows 10

I tried with both --prod and --release separately, and it is not working. I found similair issue on the forums (Building With --release --prod Styling Issues) and last comment there suggested to update ionic-angular, which I did, but it didn’t help.

#2

Any ideas? I tried finding the solution on the web but so far to no avail

#3

Still wasn’t able to solve this issue, need help, but I can add on the matter.
I was able to checkout to revision where everything was working fine, and ran diff comparison against my current implementation. I noticed that ionic-cordova-webview was of version 2.0.0 while current setup involves “^2.3.1” but I tried to downgrade back to 2.0.0, it didn’t help me neither.