Problem whenever npm install is executed in Ionic 3

Hi everyone,

I’m trying to update an Ionic 3 app from version 3.8.0 to 3.9.9 and I was following the guide on the GitHub repository (https://github.com/ionic-team/ionic-v3/blob/fa7b53608b57adb22bf9d2d4fed2b6a615220f1e/CHANGELOG.md#390-2017-11-08)

I updated the dependencies as specified in the guide but now I’m getting an error when I execute “npm install”

This is my ionic info:

cli packages: (/Users/yoyofcbmx/.nvm/versions/node/v6.10.3/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 8.0.0

local packages:

@ionic/app-scripts : 3.2.4
Cordova Platforms  : none
Ionic Framework    : ionic-angular 3.9.9

System:

ios-sim : 8.0.2
Node    : v6.10.3
npm     : 3.10.10
OS      : macOS
Xcode   : Xcode 11.4 Build version 11E146

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

And this is the error I’m getting whenever I execute the “npm install” command

npm WARN deprecated @angular/http@5.2.11: Package no longer supported. Use @angular/common instead, see https://angular.io/guide/deprecations#angularhttp
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated rollup-plugin-commonjs@8.2.6: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-commonjs.
npm WARN deprecated rollup-plugin-node-resolve@3.0.0: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-node-resolve.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN prefer global node-gyp@3.8.0 should be installed with -g
npm WARN prefer global ios-sim@8.0.2 should be installed with -g

fsevents@1.2.12 install /Users/yoyofcbmx/Code/guatemala_appgt/node_modules/fsevents
node-gyp rebuild

SOLINK_MODULE(target) Release/.node
clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated]
ld: library not found for -lstdc++
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [Release/.node] Error 1
gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/Users/yoyofcbmx/.nvm/versions/node/v6.10.3/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)
gyp ERR! System Darwin 19.4.0
gyp ERR! command “/Users/yoyofcbmx/.nvm/versions/node/v6.10.3/bin/node” “/Users/yoyofcbmx/.nvm/versions/node/v6.10.3/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /Users/yoyofcbmx/Code/guatemala_appgt/node_modules/fsevents
gyp ERR! node -v v6.10.3
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok