Problem installing ios-sim ubuntu 14.04


#1

i am trying to install ios-sim but i get this error message

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: ios-sim@4.1.1
npm ERR! notsup Valid OS: darwin
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: linux
npm ERR! notsup Actual Arch: x64

npm ERR! System Linux 3.13.0-55-generic
npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” “install” “-g” "ios-sim"
npm ERR! cwd /home/rajesh
npm ERR! node -v v0.10.25
npm ERR! npm -v 1.3.10
npm ERR! code EBADPLATFORM
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/rajesh/npm-debug.log
npm ERR! not ok code 0

Sorry if this question is redundant but i need help