Plugins does not exist

I think I solved it! I removed the ios.json in the plugins folder and then also removed the ios platform. Then ran ionic add platform and ionic build again. Now it works :slight_smile:
(I didnt reinstall cordova or ionic)


Glad to hear you got it resolved. If you have any other issue with the CLI, lets up know. We want to make sure its as stable as possible

okok, thanks for your help! Maybe you could make the build command remove the json-files in the plugin folder automagiclly?

I’m having the same problem too, I did what @tobbe suggested and worked fine, but every time I build the project I get the same error!

@zelphir Had this too a while back. This is due to an issue with Xcode 5.1 and Cordova 3.4.0. Upgrading to Cordova 3.4.1 fixes it.

Upgrade Cordova to 3.4.1 by using:

sudo npm update -g cordova

Then upgrade your project by going to your project directory and using:

cordova platform update ios

More info here:

1 Like

@coen_warmer Thanks, but I’m already with the latest versions.

but sometimes I get this error!

1 Like

When you upgraded to 3.4.1, did you upgrade your projects as well? This error is due to two files in your /platforms/ios/ folder that changed from Cordova 3.4 to 3.4.1. You can copy them by hand or let Cordova do it when you do cordova platform update ios. More information in the link in my previous post.

It seems like you have to delete your platforms + ios.json every time you add a new plugin via ‘cordova add plugin_name’. I’m on the latest version of Cordova + Ionic

1 Like

This is happening to me on cordova 3.5.0-0.2.4 and the only related change I made recently was changing this preference from false to true on config.xml:

<preference name="fullscreen" value="false" />

I’ve deleted platforms/ios and the ios.json file, re-added the platform and it still happens.

Any clue why? Thanks in advance.

When I switched up to XCode 6 and updated Cordova + Ionic, I was able to avoid the bulldozing of my project by changing the name of the directory from ddg-app to Ddg-app, and then renaming/removing my ios.json file. It saved having to redo some of the stuff within the project.

That worked for me too - thank you for posting your solution, I was beginning to think I would have to uninstall then re-install everything.

This works for me, too. I am using Cordova 4.2.0.

It looks like the problem is still not solved.

1 Like

Thank you so much, you solved my problem!

Thank you it still works with Xcode (Version 8.0 (8A218a)), and ionic 2.rc-1, with cordova 6.3.1.

agree at of ionic 2.rc1 not solved yet.

I have created an issue over here Also included the detailed comparing both success project, and failed project.

In short, ionic build command which is necessary to take changes into effect won’t anymore copy plugins’ source file into target project.

If there’s any workaround to reduce time wasted on starting over every time to test things on iOS would be great.

I love you tobbe <3 cordova 6.5.0 ionic 2.2.1

I faced same issue for IOS.

I just removed ios platform and again added it worked for me

I think I caught the error in 2021: basically when you add a new plugin via npm it doesn’t download required dependencies. This is the case of HTTP Native which requires Cordova-plugin-file.
In fact after removing iOS platform and exec “ionic capacitor add ios” this is the output:

✔ add in 19.25ms
✔ Copying web assets from www to ios/App/public in 349.22ms
✔ Copying native bridge in 4.05ms
✔ Copying capacitor.config.json in 2.00ms
  Found 3 Cordova plugins for ios (2.1.0)
    com.paypal.cordova.mobilesdk (3.5.0)
    cordova-plugin-advanced-http (3.1.0)
✔ copy in 446.20ms
✔ Updating iOS plugins in 13.57ms
  Found 0 Capacitor plugins for ios:
[info] installing missing dependency plugin cordova-plugin-file
✔ Updating iOS plugins in 20.76ms
  Found 4 Cordova plugins for ios (2.1.0)
    com.paypal.cordova.mobilesdk (3.5.0)
    cordova-plugin-advanced-http (3.1.0)
    cordova-plugin-file (6.0.2)
✔ Updating iOS native dependencies with "pod install" (may take several minutes) in 4.81s
✔ update ios in 13.64s

look [info].