Peeker view does not have "Done" and forward/back arrows


#1

The iOS peeker view on my Ionic app does not have the HTML5 default “Done” and forward/back buttons on the top bar. I am using Ng-options. What I want is this effect:

How do I get these features back on my peeker view? Thank you.

My code looks like this:

      <form name="offerList" ng-submit="addOffer()" style="margin-left:auto; margin-right:auto">
        <label class="item item-input item-select">
          <span class="input-label">Ride:</span>
          <select ng-model="offer.ride" ng-options="ride.value as ride.name for ride in rides"></select>
        </label>
        <label class="item item-input">
          <span class="input-label">Return time:</span>
          <input ng-model="offer.time" class="givepass-time-input" type="time" />
        </label>
        <label class="item item-input item-select">
          <span class="input-label">Your location:</span>
          <select ng-model="offer.location" ng-options="location.value as location.name for location in locations"></select>
        </label>
        <label class="item item-input item-select">
          <span class="input-label">Number of passes:</span>
          <select ng-model="offer.number_give" ng-options="number_give.value as number_give.name for number_give in numbers_give"></select>
        </label>
        <label class="item item-input item-select">
          <span class="input-label">Free or trade:</span>
          <select ng-model="offer.comment" ng-options="comment.value as comment.name for comment in comments"></select>
        </label>
        <br>
        <button class="button button-full button-dark">
          submit offer
        </button>
        <div class="errorMsg">{{ errorMsg }}</div>
      </form>

#2

Do you have the keyboard plugin installed and are you hiding the accessory bar?


#3

@mhartington thanks for the response. Sheepish reply. Yes, I did! But I didn’t know that I did or that this was called the accessory bar of the keyboard plugin. Some investigation led me to discover some code from the tutorial I am using was hiding it. Thank you!


#4

Good to hear you got it taken care of