Not performing Ionic build for project type: ionic1. > cordova build ios


#1

I am struggling to get a build of an Ionic 1 project.

I renamed my ionic.project to ionic.config.json

I can run Ionic serve and that app starts, but it wont go past the intro screen. The same goes for running it the simulator or actual device. Debugging shows no errors at all.

Any suggestions are appreciated.

li packages: (/usr/local/lib/node_modules)
@ionic/cli-utils : 1.14.0
ionic (Ionic CLI) : 3.14.0

global packages:
cordova (Cordova CLI) : 7.1.0

local packages:
Cordova Platforms : ios 4.5.2
Ionic Framework : ionic1 1.1.1

System:
ios-deploy : 1.9.2
Node : v6.11.4
npm : 3.10.10
OS : macOS Sierra
Xcode : Xcode 9.0.1 Build version 9A1004

Misc:
backend : pro


#2

Bump - also having this issue for both Android and iOS builds. Existing ionic 1 project with cli upgraded to 3.19.0.

In my case, ionic serve works just fine, but the “Not performing Ionic build for project type: ionic1” appears when building for devices. Technically, the builds succeed, but it only produces a blank screen after the splash goes away. No console errors.

I’ve found one stack overflow post that recommends reinstalling a version of the cli before 3.0, but I would prefer to use the latest versions for iPhone X support.

Any suggestions? Ionic Info below:

cli packages:

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

global packages:

cordova (Cordova CLI) : 7.1.0 

local packages:

Cordova Platforms : android 6.3.0 browser 5.0.1 ios 4.5.4
Ionic Framework   : ionic1 1.3.4

System:

Android SDK Tools : 25.2.3
ios-deploy        : 1.9.2 
ios-sim           : 5.0.1 
Node              : v9.2.0
npm               : 5.3.0 
OS                : macOS High Sierra
Xcode             : Xcode 9.1 Build version 9B55 

Misc:

backend : legacy

#3

That is correct, “Ionci build” refers to a step that is only necessary with newer projects.

White screen with no errors at all?
Does it work on Android?


#4

Good to know! I couldn’t find documentation about that warning anywhere, so I’m glad it’s not the issue.

White screen appears on Android after splash screen. I can tell it’s running through some of the code - I’m using Chrome to debug the app on a device and it seems to be initializing the first screen, but nothing displays. iOS has actually worked when running on a device, but fails every time on the simulator. Exits as soon as the splash screen times out.


#5

That’s strange. Same problem with a new project created with ionic start?


#6

No issues with a fresh Ionic 1 project, it was able to run and attach just fine.

In fact, I was just able to get the app running on the iPhone X simulator after waiting an extremely long time. It took 3 whole minutes to start up and get past the splash screen this time.

Here’s what I did:

  1. remove the platform
  2. re-add it
  3. run pod install on the platform/ios directory
  4. open the workspace with XCode
  5. attempt to run on the iPhone X simulator… and have it fail once
  6. try a second time, and it worked… after 3 minutes startup time

So, it’s worked… but I don’t know what’s different than before, or if it will also take 3 minutes to start up on a physical iPhone X. Typically startup time for my app is around 5-10 seconds, even on a simulator. It would be funny if this wasn’t like the majority of my experiences updating ionic with new versions or plugins.

Edit: While monitoring output from the iPhone X simulator, it appears that some plugins are taking an excessively long time to start up. Almost a full minute in some cases. As far as Android goes, still getting the white screen, but I did notice the following appearing in the console:

deviceready has not fired after 5 seconds.
Channel not fired: onCordovaInfoReady
Channel not fired: onFileSystemPathsReady
Channel not fired: onCordovaConnectionReady

After a quick search, it appears that it could be any plugin at all preventing deviceready from firing. At least it’s consitent with what I’m seeing in the output from the iPhone X simulator, so I know to focus on the plugins next.