No suitable image found on gulp-sass


#1

Hi, can anyone explain what went wrong? i’m encountering this error when serve myApp, search google around but no luck, tried methods:
1.npm install
2.npm install gulp
3.npm install gulp-sass
4. add sudo to above commands and rerun
5. add -g option to install globally

really can’t find what went wrong. please help.

#########################
ionic $ module.js:522
var nodePath = process.env[‘NODE_PATH’];
^
Error: dlopen(/Users/plato/Dev/myApp/node_modules/gulp-sass/node_modules/node-sass/vendor/darwin-x64-node-0.12/binding.node, 1): no suitable image found. Did find:
/Users/plato/Dev/myApp/node_modules/gulp-sass/node_modules/node-sass/vendor/darwin-x64-node-0.12/binding.node: truncated mach-o error: segment __TEXT extends to 864256 which is past end of file 179563
at Error (native)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object. (/Users/plato/Dev/myApp/node_modules/gulp-sass/node_modules/node-sass/lib/index.js:188:15)
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)


#2

I got this error when after running. ionic setup sass.

It was solved by doing a npm update