No ENO ENT No such file or directory open c:\package.json

New to ionic Have been trying to get sqlite installed for a day or two!
Have run the ionic cordova plugin add cordova-sqlite-storage in my project folder
but running the the npm command I keep getting the above message .
What am I missing ? have re-run the npm install program . What folder should I run the npm command in ?have tried running it in my project folder but this trashes my project . Any help greatly appreciated

Yes, you must run it in your project folder. Define “trashes”.

Thanks for responding
I get npm warn @ionic/storage @2.01 requires a peer of @angular/core@ but none is installed you must install peer dependancies
simiar messages for
@ionic/storage @2.01 requires a peer of rxjs
@ionic-native/sqllite 3.14.0 requires a peer of @ionic-native/core3.6.0
@ionic-native/sqllite 3.14.0 requires a peer of @angular/core
@ionic-native/sqllite 3.14.0 requires a peer of rxjs@5.01

I presumed that I was getting these because at the end it gives message
Added i package and removed 629 packages

Running with ionic serve then gives a page fulll of additional error message

Please post package.json.

“name”: “elite-schedule-app”,
“version”: “0.0.1”,
“author”: “Ionic Framework”,
“homepage”: “”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
“dependencies”: {
"@agm/core": “^1.0.0-beta.0”,
"@angular/common": “4.1.0”,
"@angular/compiler": “4.1.0”,
"@angular/compiler-cli": “4.1.0”,
"@angular/core": “4.1.0”,
"@angular/forms": “4.1.0”,
"@angular/http": “4.1.0”,
"@angular/platform-browser": “4.1.0”,
"@angular/platform-browser-dynamic": “4.1.0”,
"@ionic-native/core": “3.7.0”,
"@ionic-native/splash-screen": “3.7.0”,
"@ionic-native/sqlite": “^3.14.0”,
"@ionic-native/status-bar": “3.7.0”,
"@ionic/storage": “2.0.1”,
“angular2-google-maps”: “^0.17.0”,
“cordova-android”: “^6.2.3”,
“cordova-plugin-console”: “^1.0.5”,
“cordova-plugin-device”: “^1.1.4”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.2”,
“cordova-plugin-whitelist”: “^1.3.1”,
“cordova-sqlite-storage”: “^2.0.4”,
“ionic-angular”: “3.2.1”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“lodash”: “^4.17.4”,
“moment”: “^2.18.1”,
“rxjs”: “5.1.1”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.10”
“devDependencies”: {
"@ionic/app-scripts": “1.3.7”,
"@ionic/cli-plugin-cordova": “1.0.0”,
"@ionic/cli-plugin-ionic-angular": “1.0.0”,
"@types/lodash": “^4.14.64”,
“typescript”: “2.2.1”
“description”: “An Ionic project”,
“cordova”: {
“plugins”: {
“cordova-sqlite-storage”: {},
“cordova-plugin-console”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-whitelist”: {},
“ionic-plugin-keyboard”: {}
“platforms”: [

Some things a bit out of date, but not the carnage I was expecting. Do you still get peer dependency warnings if you just run npm i?

Get different warnings now . These related to angular-google-maps 0.17.0 requires @angular/common @2…3.1 and @angular/Core @2.3.1
Added 856 packages though

That’s bad. If you can’t find a newer version of angular-google-maps that is happy with Angular 4, I would look into finding some sort of replacement for it.

Ok thanks very much for your help . Very much appreciated !