Navigation navbar transition issue


#1

Hello, I’m facing a bizzare issue which I’m not sure what causes it. The problem is affecting the navbar.

See this cropped screencast:

The problem I’m speaking about is clearly visible after second 0:38 of the video.

What is causing that?

Navigation is taking place inside last tab which is configured as follows:

$stateProvider
...    
.state('tab.altro', {
                url: '/altro',
                views: {
                  'tab-altro': {
                    templateUrl: 'templates/tab-altro.html',
                    controller: 'AltroCtrl'
                  }
                }
              })
              .state('tab.peez_altro', {
                url: '/peez_altro/:peez_id/:from',
                views: {
                  'tab-altro': {
                    templateUrl: 'templates/peez.html',
                    controller: 'PeezCtrl'
                  }
                }
              })
              .state('tab.profilo', {
                url: '/profilo',
                views: {
                  'tab-altro': {
                    templateUrl: 'templates/profilo.html',
                    controller: 'ProfiloCtrl'
                  }
                }
              })
              .state('tab.user_peez_list', {
                url: '/user_peez_list/:user_id',
                views: {
                  'tab-altro': {
                    templateUrl: 'templates/peez_list.html',
                    controller: 'PeezListCtrl'
                  }
                }
              })

Looks like this issue happens whenever i navigate to a child page of a tab’s first child page.

I mean: the transistion is correct if I remain “one level” away from tab content, like:

tab -> child page - navbar transition ok

but if the sequence is (two level away):

tab -> child page -> child page - navbar transition broken

Am I wrong? What do you think?

P.S. If you see some smooth transition between tabs, I am running a self modified version of ionic.bundle,js.


#2

Solved, sorry.

I messed up my css and was abusing hide-nav-bar=“true” on tabs.