Live Web Server launches IE, how can I change this?


Hi, I am testing on Ionic live server using the command ‘ionic serve’ but it keeps launching Internet Explorer. I am on Windows 8.

I changed default web browser to Chrome and it still launches the test app in IE.

How can I change this?


Hmm, as far as I know, live-reload should load the default browser, so it sounds it’s a windows issue. Are you sue that Chrome is set to the default browser?


Yes, I’m positive.

i’m being told that my web browser preferences are polled by Node.js, of which polls from Windows API. Ionic framework assumes you know this as you were explictly told it relies on Node.js.

He told me to edit the Windows registry but I don’t know how.


Check in your preferences ( defoult programs ) if Chrome is checked as defoult .html viewer/ browser. I don’t sugguest people ot otouch regedit.exe without knowledge, in the Windows heart, and some changes may make u chrash all your sistem, trust me.

Just check it, and if it doesn’t work tell me and i will help you, I work with windows machine all my life :slight_smile:


Still doesn’t work.

Control Panel\Programs\Default Programs\Set Default Programs

Google Chrome is set to default.

I don’t know what else I can do.


Can u show a screshot of your default settings? like mine, check if they are all checked ( html, htm etc.)

And this porblem happend always , I mean with all pages you open ( some page.html ) or only when u run ionic serve?

Check my screenshot


Screenshot is attached. Default is set to Chrome


Okey lets see it deeper.

Open regedit.exe and go here:


As you can see i have Dragon ( modificated Chrome browser by COMODO ) as default browser, so see what u have there. Go and change “DragonHTML” to “ChromeHTML” and that should made Chrome default browser viewer.

If not i guess u have some problem with entire regedit, and may CCleaner ( registry fixer ) can help you.


it worked, awesome! :slight_smile:


Glad to help you ! :slight_smile:


I can test the project in IE using ionic serve.
But when I make chrome or firefox the default, I receive an error.