Library not found for -lFirebaseCore in xocde


This plugin is working fine for android but when i am building ionic 4 project in xocde it’s showing these errors

ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/FirebaseCore’
ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/FirebaseInstanceID’
ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/FirebaseMessaging’
ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/GoogleUtilities’
ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/Protobuf’
ld: warning: directory not found for option ‘-L/Users/syedaqdaszaidi/Library/Developer/Xcode/DerivedData/ShiaFM-cmchzodxxqifygckxxojpqogtqnp/Build/Products/Debug-iphonesimulator/nanopb’
ld: library not found for -lFirebaseCore
clang: error: linker command failed with exit code 1 (use -v to see invocation)

What I have already done
downgrade Cordova form 9 to 8 version - not working
install pod and update in platform/ios - not working
open workspace file instead of xcodeproj - not working (showing another error - could not find a valid GoogleService-Info.plist in your project.)


FCM plugin is working fine for ios but in android, it’s making version conflict with firebase dynamic link, that’s why I used cordova-plugin-firebase-messaging this plugin

I have been searching since last 3 days, please help

1 Like

I have the same issues. Please help here.

I have submitted the answer on github, please check
it’s working for me