Ld: framework not found IOSurface for architecture armv7

Hi all,
i have an error on ionic cordova build ios
Any suggestion is appreciable
error:linker error ld: framework not found IOSurface for architecture armv7
Thanks in advance

Ionic Info

cli packages: (/usr/local/lib/node_modules)

    @ionic/cli-utils  : 1.19.2
    ionic (Ionic CLI) : 3.20.0

global packages:

    cordova (Cordova CLI) : 7.1.0 

local packages:

    @ionic/app-scripts : 3.1.10
    Cordova Platforms  : android 6.3.0 ios 4.5.4
    Ionic Framework    : ionic-angular 3.9.2


    ios-deploy : 1.9.2 
    ios-sim    : 5.0.9 
    Node       : v8.10.0
    npm        : 5.6.0 
    OS         : macOS Sierra
    Xcode      : Xcode 8.2.1 Build version 8C1002 

Environment Variables:

    ANDROID_HOME : /Library/Android/sdk/


which solved same question

Hi@ reedrichards thanks for the reply
But in my case my xcode version is 8.2.1
Is there any solution without update my xcode?

I don’t know I just googled quickly your issue. According what I read the problem is that the project was build with Xcode 8 or 9 and then opened in Xcode 9 or 8. According them the solution is to clean the project and rebuild it. So spontaneously I would say

  1. Remove and add your platform and try again (don’t forget to manually change what you manually already changed)

if doesn’t work

  1. Why not using Xcode 9, in any case, if you want to submit your app you gonna need it if I’m not mistaken

But like I said I just googled really quickly your issue, I might say something totally wrong and if it’s the case, plz accept my apologies

@reedrichards Anyway thanks for your suggestion.:smile:
Now the error is ld: framework not found FileProvider for architecture x86_64
Do you have any suggestion for me?

sounds like XCode v9 might be the pass https://stackoverflow.com/a/46483043/5404186

but only a suggestion

ok thanks.Let me try that may help.

Was this resolved for you? Did you have to update

Are you asking me? I didn’t faced the error, I was just trying to help by pointing what I found

Was this resolved for you? Did you have to update

I see well thank you for being so helpful im having the same error