[issue] Slides not working on PC platform

Hi

while the slides works on mobile platforms, it doesnt work on PC/Mac.

on PC, when tried to drag/swiped on a slide to next one it just bounds back right away.

Is this an issue or there’s a work around?

1 Like

Could you provide a demo in a git repo? I have tested slides personally and they do in fact work in a browser.

i m new to programming and not really into git yet…
i m trying to get recreate a demo on Plunker, then again I dunno how to import ViewChild form ‘@angular.core’ in Plunker… Is there a template project file on punker or codepen I can quick start by editing with?

When I encounter the slides problem I was basically just copying the code from the slides source document into my project on mac and did a ionic serve. in chrome (toggle responsive mode) and in simulator it works fine but in normal browser mode (os=core) it only shows the first slide, only one pager dot is shown and when i tried to drag/swipe, sure the second slide is there but it will bounce back to the first slide.

even stranger things happen:
after lot of testing, i discovered that if I resize the window after the page is loaded, the slides works again. it doesnt matter what size my window is, long as the page is loaded and i resize it a bit, the slider will work fine. I didnt add much css into it, but i guess it’s sth to do with css.

so if there’s a plunker template to start with i will try to recreate the demo.

I just checked again, no it;'s not about CSS… for example the pagination only renders one spot, even though when dragged I can see the next slide is seemed to be attached. and whenever I resize the window after page is loaded, everything goes back to normal. could this happen becuz some of the events were fired too early before the page is loaded? so when i resize the window somehow get it working again?

when dragged on browser:

after i resize the window a bit:

Hi @mhartington,

sorry for many posts, i solved this issue by doing this:

i put the slides= [{ ...some arrays }] inside a ionViewDidEnter(){} and then it all worked normal.

I dunno how this happened and why this hv solved the issue, but i guess this could be useful to the community?

I am fetching same issues. here i’ve initialise the array of image inside
ngOnInit() {
this.imgs = [‘http://lorempizza.com/380/240’,
http://dummyimage.com/250/ffffff/000000’,
http://lorempixel.com/g/400/200/’,
http://lorempixel.com/g/400/200/sports/’];
}