Ios rejection, app too slow

I submitted an app into Ios in the beta testing section, i have already a few builds into production, however this is the output of the Ios review Board, basically it says that the loading screen shows forever when connected to IPV6 ip’s, how do i even fix this, and why complain now when the last 4 builds just worked?


Hmm not a whole lot there. They mention screenshots, are you able to post them?
For the most part, nothing should change for IPV6 in your frontend code.

The only issue that could come up is when dealing with APIs that hardcodes the IP address.
Looks like you got some debugging to do :smile:

My guess is something went wonky during the review. Do you have a timeout check when you make your network calls? Often we assume it all works (except when it doesn’t) when accessing remote servers. By providing a timeout system, you can respond to the failure (including no network), and gracefully avoid this issue.

Good luck

@mhartington This is the related screenshot.

@ChrisGriiffith Please note that it says it keep loading, it doesn’t even go through the splash screen, in that moment the app isn’t supposed to make any network calls:

Also how am i supposed to test that? idk enough about IPV6 to know how to test with it.

maybe disable wifi and internet etc and then run the app and see if it stucks, maybe its trying to connect somewhere and waits for the connection which eventually times out.

I’m certain it doesn’t, we have tested the app with wifi, no wifi and lie-fi :slight_smile: from before even opening the app and never an issue, however we tested most of this in android, let me test in Ios then i’ll be back Thursday with results.

Worse comes to worse, you can reply to apple and ask for some more clarification on how they were able to break your app

Same here, they say that they are not able to login using facebook because it keeps loading forever. I am using Heroku Server and I am not hardcoding IP addresses… Apple even mentions to test the app in a IPv6 network simulation


but when I test it, it works fine. So I wrote them asking for help… And that was the reply…

I have tried to follow the tutorials on the link above, trying to emulate a IPv6 network but everything seems to work fine.
I have searched a lot over the web looking for a way to fix this problem but I find it really hard to find something about it when I can not even reproduce the crash.
I have followed every recommendation such as not having hard IPs pointing to my server and instead having a URI where the DNS would be able to solve it, but none of it seems fix the problem.
So I am writing to get a clue or a little help on how to make it work . I have attached a video emulating the IPv6 network and showing that the app is working, I do not know where am I mistaking, I would deeply appreciate any help given.


Thank you for your reply. Please note that the app does not crash at the times of review, it simply loads indefinitely. We’ve attempted to login using various devices and none of them allowed us to do this successfully.

Please make any changes you see needed to bring this app into compliance with the App Review Guidelines, then resubmit for review.

Best regards,

App Store Review

Performance - 2.1

We discovered one or more bugs in your app when reviewed on iPhone running iOS 9.3.3 on Wi-Fi connected to an IPv6 network.

Specifically, the app continues to load indefinitely when we attempted to initiate a login.

We’ve attached screenshot(s) for your reference.

Next Steps

Please run your app on a device while connected to an IPv6 network (all apps must support IPv6) to identify the issue(s), then revise and resubmit your app for review.

If we misunderstood the intended behavior of your app, please reply to this message in Resolution Center to provide information on how these features were intended to work.

For new apps, uninstall all previous versions of your app from a device, then install and follow the steps to reproduce the issue(s). For updates, install the new version as an update to the previous version, then follow the steps to reproduce the issue(s).


For information about supporting IPv6 Networks, please refer to Supporting IPv6 DNS64/NAT64 Networks and About Networking

If you have difficulty reproducing a reported issue, please try testing the workflow described in Technical Q&A QA1764: How to reproduce bugs reported against App Store submissions.

If you have code-level questions after utilizing the above resources, you may wish to consult with Apple Developer Technical Support. When the DTS engineer follows up with you, please be ready to provide:

  • complete details of your rejection issue(s)
  • screenshots
  • steps to reproduce the issue(s)
  • symbolicated crash logs - if your issue results in a crash log

I will ask to ios support however i’m probably going to get the same response, weird thing this only happens with beta versions, the normal ones don’t have this issue, i have like 10 versions already in the project pushed to itunes and now that i try beta versions for TestFlight it breaks.

For me, the problem was solved. It had nothing to do with IPv6 like they said it did, neither heroku or ionic.
The tester did not have a picture in their facebook testing profile and I had no validation for that.
The odd thing was that the code was accepted in all of the previous versions, they had pictures… And now, it was just a coincidence with no pic and new IPv6 thing. Well, what I want to say is that they are reporting as IPv6 errors, issues that are not necessarily related to IPv6 issues.

PS: Before we could find the real issue, we were putting logs everywhere to pop as alert to find out where the app breaks, so when they would sent the print screen we would know where exactly where the problem were.

I’m not sure why our breaks, i have added the ionic-native splash screen plugin to hide the splash on app ready instead of letting it do it itself, i’ll see if that works out ok and come back.

I think i found the reason, i’m going to test and go back.

For the time being my app didn’t work ok in android because it was lacking the database, it wasn’t creating the tables it was expected to so the app wouldn’t log in as expected, tough it did go through the splash screen so i’m still skeptical.

The solution to that was to update ionic and cordova, ionic state reset and removing the cordova-plugin-compat.

I have three plugins depending on the cordova-plugin-compat plugin:

  1. cordova-plugin-camera
  2. cordova-plugin-file
  3. cordova-plugin-media

Is there any other solution?

Hi luchillo17, have you fixed the issue? I have similar rejection reason which says my splash screen spun indefinitely but when I test it works fine…have no clue what to do next, please help

Sorry man, that was 2 years ago, i don’t work in the project any more so i don’t remember, though my previous comment does look like i made it, have you tried what i say i did in such comment?

Thanks for your reply. I already have invoked hide manually before I submit my app but still get stuck(have no clue, never encountered this when test by myself) I thought it was August 2018 when you had this issue. Sorry to bother!