Ios emulation does not work due to dependency on Xcode 6.0


#1

when I try to emulate ios I recently get the following message: “You need to have at least Xcode 6.0 installed – you have version 5.0.1.”

Upgrading to Xcode 6.0 is not an option at the moment, is there anyway to run with Xcode 5.x? This worked in the pas but I am a bit puzzled what exactly is forcing the dependency on Xcode 6.0.

Thanks,

Mark


#2

This message is coming from ios-sim (https://github.com/phonegap/ios-sim):

Supports Xcode 6 only since version 3.x.

You may be able to get around this by downgrading ios-sim or phonegap.


#3

Great, downgraded ios-sim to version 2.0.1.

Works as a charm again!

Thanks!


#6

I did this and then ran the xcode project and it seemed to install but ‘ionic emulat’ still says no ios-sim found.


#7

I’ve used npm to install ios-sim with the following command.

npm -g install ios-sim@2.1