Ionix start stops working after 'Saving your Ionic app state of platforms and plugins'

when I try to start an new project (regardless with v1 oder v2) I always get this:

GS-MAC:ionic grischa$ ionic start I1
Creating Ionic app in folder /Users/grischa/Dropbox/Development/ionic/I1 based on tabs project
Downloading: https://github.com/driftyco/ionic-app-base/archive/master.zip
[=============================]  100%  0.0s
Downloading: https://github.com/driftyco/ionic-starter-tabs/archive/master.zip
[=============================]  100%  0.0s
Installing npm packages...

Adding initial native plugins
[=============================]  100%  0.0s

Adding in iOS application by default
add to body class: platform-ios
Downloading: https://github.com/driftyco/ionic-default-resources/archive/master.zip
[=============================]  100%  0.0s
Saving your Ionic app state of platforms and plugins

Then the process stops working. There is no error message or anything.

When I Cntr-C and try to run the app with ionic serve the browser does not open, the applications stops working and then gives this error:

GS-MAC:i2 grischa$ ionic serve
(node:40184) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

Running 'serve:before' gulp task before serve
[23:53:57] Starting 'clean'...
[23:53:57] Finished 'clean' after 99 ms
[23:53:57] Starting 'watch'...
[23:53:57] Starting 'sass'...
[23:53:57] Starting 'html'...
[23:53:57] Starting 'fonts'...
[23:53:57] Starting 'scripts'...
[23:53:57] Finished 'scripts' after 122 ms
[23:53:57] Finished 'html' after 134 ms
[23:53:57] Finished 'fonts' after 147 ms
[23:53:59] Finished 'sass' after 2.09 s
8.4 MB bytes written (71.90 seconds)
Caught exception:
 RangeError: Maximum call stack size exceeded
    at RegExp.[Symbol.match] (native)
    at String.match (native)
    at Object.exports.fromSource (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/convert-source-map/index.js:122:19)
    at DestroyableTransform.sourceMapInit [as _transform] (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/gulp-sourcemaps/index.js:36:27)
    at DestroyableTransform.Transform._read (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/through2/node_modules/readable-stream/lib/_stream_transform.js:159:10)
    at DestroyableTransform.Transform._write (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/through2/node_modules/readable-stream/lib/_stream_transform.js:147:83)
    at doWrite (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/through2/node_modules/readable-stream/lib/_stream_writable.js:313:64)
    at writeOrBuffer (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/through2/node_modules/readable-stream/lib/_stream_writable.js:302:5)
    at DestroyableTransform.Writable.write (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/through2/node_modules/readable-stream/lib/_stream_writable.js:241:11)
    at write (/Users/grischa/Dropbox (FH St. Pölten)/Development/ionic/i2/node_modules/vinyl-buffer/node_modules/readable-stream/lib/_stream_readable.js:623:24) 

Mind letting us know? https://github.com/driftyco/ionic-cli/issues

@Grischa It’s probably related to the following issues, I’ll suggest you to subscribe/vote for them:

Solution: just to keep you updated if anybody should read this post…

The problem was “funny” characters in the path of the project and with “funny” I mean german Umlauts and blanks.

When I moved the project to another location everything worked.

1 Like

Same here. My pathname had “Dropbox (Personal)” in it. When I used ionic start outside of Dropbox it worked fine.

1 Like