Ionic V1 - Publishing error - Google Console developer error (In French sorry)


#1

hello,

I spend the day to try to understand and change android sdk versions in the config.xml, but I still get this error when trying to publish the app on the GOOGLE DEVELOPER CONSOLE (Alpha test)

Does anyone knows how to fix it ?

Thank you.


#2

Anyone encounter this issue ??


#3

well it would help if that error was in english. this happening because you have multiple apks qualifying for a device. Simply unpubllish the older apks from dropdown menu besides apk.


#4

Hi @Sumeet123 thank you for your answer.

I tried to change the language but it’s like impossible on the google developer console.

Google trad :

Can not publish this configuration for the following reason :
Devices which previously corresponded to the 3812 version can not move to the previous version 432. This can occur in the following cases:
API levels in the 19+ range and
Output level containing any element [ ALPHA] and
screen formats containing any element [small , normal , large, xlarge ] and
native platforms containing any element [ armeabi - V7A ] and
Features containing all the elements [ android.hardware.LOCATION , android.hardware.location.GPS , android.hardware.location.NETWORK , android.hardware.screen.PORTRAIT , android.hardware.TOUCHSCREEN , android.hardware.WIFI ] .

I did unpublish the APK look :
the 3812 version state means : “on Alpha Version, will be canceled”.


#5

Check if you incremented the version number for the new apk ! your version number should be greater than 0.0.381 . it should be atleast higher than previous one. try changing 0.0.43 in config.xml to 0.0.382

present apk is showing version 0.0.43 which is older and not acceptable


#6

but 0.0.43 > 0.0.382 no ?

I changed the config.xml with


<widget id="net.myapp.www" version="0.0.43" xmlns="http://www.w3.org/ns/widgets" xmlns:cdv="http://cordova.apache.org/ns/1.0" xmlns:gap="http://phonegap.com/ns/1.0">


#7

LOL your question just confused me more :joy:
but i dont think so because if it was this error wont appear ! may be i am wrong just give it a shot and try 0.0.382 or 0.0.430

it should be a increasing integer. obviously 43 < 382 . you looking at it separate parts as 4.3 and 3.8.2.

[ removed to not confuse others ]

if i am confusing you refer this https://en.wikipedia.org/wiki/Software_versioning


#8

OK :slight_smile: Then I retry with 0.0.431 :smiley:


#9

@Sumeet123 it worked dude !
With version 0.0.431

The hell, I’m struggling till 2 days :slight_smile:

Thank you so much you rock.
I’d buy you a beer If I could :slight_smile:

Thanks :slight_smile:


#10

its fine :slight_smile: glad to help. enjoy…