"ionic start" failed without error/exception


#1

Hi, I’m new to ionic.

I’m trying to follow the Getting Started instructions, but when I run “ionic start myApps tabs” I get the following output:
[ec2-user@ip-172-31-43-142 ~]$ ionic start myApp tabs
Running start task…
Creating Ionic app in folder /home/ec2-user/myApp based on tabs project
DOWNLOADING: https://github.com/driftyco/ionic-app-base/archive/master.zip
[ec2-user@ip-172-31-43-142 ~]$

Looks like “ionic start” just aborted there but no error is displayed.

I’ve checked that I’m not behind a proxy.

The only thing I can think of is when I install ionic I got 2 warnings:
[ec2-user@ip-172-31-43-142 ~]$ sudo npm install -g ionic
npm WARN engine xmlbuilder@2.2.1: wanted: {“node”:“0.8.x || 0.10.x”} (current: {“node”:“v0.11.14-pre”,“npm”:“1.4.14”})
npm WARN package.json github-url-from-git@1.1.1 No repository field.

I don’t know if that’s related.

Anyone’s seen this issue?


#2

I’m on Amazon EC2 with Amazon Linux.

Has anyone seen this problem?


#3

No one :(?

Can someone point to me where I can find the breakdown of “ionic start” command then?

I understand that this is just a wrapper over Cordova/gulp commands, right?

Thanks!


#4

Have you tried to install a regular cordova project?


#5

Hi ahuwaa

Thanks. I have tried. Is there a tutorial somewhere I can follow?


#6

I believe installing the ionic CLI will include cordova. try running a “cordova --v” to make sure. If not, just follow whatever approach you need with this:

http://cordova.apache.org/docs/en/3.5.0/guide_overview_index.md.html#Overview

It contains links to the tutorials.