Ionic serve --lab not opening in browser


#1

Running ionic serve --lab does open the expected lab view in my browser.

It only informs me that: dev server running: http://localhost:8100/

If I open this, it shows the app in full screen in the browser, rather than the lab view.

How do I access the lab view in my browser?

EDIT: I got it to working using the --browser flag. I’m not sure why it wasn’t autolaunching previously. That’ll teach me for premature posting…


#2

Which OS? and what browser?

Glad you got it working


#3

elementary OS. It works with any browser I have using the --browser option (chromium, epiphany, vivaldi) but it doesn’t launch a browser tab without it.

Interestingly, launching the docs via the command line does in fact open the default browser, only the serve command doesn’t.


#4

have you tried this after ionic serve --lab

http://localhost:8100/ionic-lab


#5

FWIW this is what I was missing myself. The browser was just opening to the base :8100/ page instead of /ionic-lab. Thank you!


#6

Open http://localhost:8100/ionic-lab and select a selector of platforms on the right, select you want to


#7

It’s worked in my case.