Ionic run android works BUT apk does not access internet

@originalcode, I have the same problem. Any updates? have you solved this issue?

I still have the same problem: ionic serve work fine, even uploading the app on ionic view works fine, but when I build the app and put it on the Play Store, I get no internet… I tried all the solution above, but nothing worked so far.

Hi guys, do you have a solution about this problem ?

problem solve for me i just update everything and adjust the proxies hehe

Has anyone every seen this happen for just a subset of Android devices? I am having this problem on just these devices…

Android arrows F-05J 7.1.1
Android SO-01J 8.0.0
Android SHV37_u 6.0.1
Android SO-03J 7.1.1
Android d-01j 7

Change your code at project\resources\android\xml like above

<?xml version="1.0" encoding="utf-8"?>
<network-security-config>
     <base-config cleartextTrafficPermitted="true"/>
</network-security-config>
4 Likes

you saved mi life! after hours of struggling this solved my issue, thanks!

Thats Great… :slightly_smiling_face:

Hey guys,

I’m developing an application with Ionic/Angular as frontend and Java Spring boot as backend.

When they’re both running om my laptop the communication between them works perfectly. Currently i’m trying with the APK (both debug and signed) on my mobile phone, but it cannot make any calls to my backend. I have tried all the above suggestions but with no success.

Whitelist plugin is added, permissions are set, access-origins (*) is set and allow-navigation (set to wildcard). Am I missing something?

Thanks in advance!

Are you missing HTTPS?

I had similar symptoms, changing my API from HTTP to HTTPS solved it right away.

From Android 9 Pie and up, all requests need to have encryption. The SO answer below shows how to get around it if you need http.

kkraus, thank you so much. I would have wasted even more days looking for the cause of the problem.

I think it also depends on the Android version. The missing intermediate cert didn’t cause a problem on my phone with Android 8. But on another phone with Android 10 it failed.

I could confirm with https://www.ssllabs.com/ssltest/ , that the intermediate cert was missing on the server. In my case it is an IIS7.5. Steps to install the missing certs are described here: https://www.xolphin.com/support/IIS/IIS_-_Install_root_and_intermediate_certificates