Ionic run android java sdk error


#1

So, I’ve searched a lot and found nothing on google/stack about my error, so here goes the message that displays when I run ionic run android

~/Documents/app/myapp $ ionic run android
^[[3~ ✗ (node:9970) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
Running command: /home/wagner/Documents/apps/myapp/hooks/after_prepare/010_add_platform_class.js /home/wagner/Documents/apps/myapp
add to body class: platform-android
ANDROID_HOME=/home/wagner/android-sdk-linux
JAVA_HOME=/usr/lib/jvm/java-7-oracle
No target specified, deploying to emulator
Error: android: Command failed with exit code 1 Error output:
Exception in thread "main" java.lang.NullPointerException
    at java.io.File.<init>(File.java:277)
    at com.android.sdklib.internal.avd.AvdManager.parseAvdInfo(AvdManager.java:1623)
    at com.android.sdklib.internal.avd.AvdManager.buildAvdList(AvdManager.java:1584)
    at com.android.sdklib.internal.avd.AvdManager.<init>(AvdManager.java:357)
    at com.android.sdklib.internal.avd.AvdManager.getInstance(AvdManager.java:380)
    at com.android.sdkmanager.Main.getAvdManager(Main.java:295)
    at com.android.sdkmanager.Main.displayAvdList(Main.java:1185)
    at com.android.sdkmanager.Main.doAction(Main.java:321)
    at com.android.sdkmanager.Main.run(Main.java:151)
    at com.android.sdkmanager.Main.main(Main.java:117)

my ionic info:

Cordova CLI: 6.2.0
Gulp version:  CLI version 1.2.1
Gulp local:   Local version 3.9.1
Ionic Framework Version: 1.1.0
Ionic CLI Version: 1.7.15
Ionic App Lib Version: 0.7.2
OS: Distributor ID:	Ubuntu Description:	Ubuntu 16.04 LTS 
Node Version: v5.7.0

Obs: about the graceful-fs, this is the lastest version
npm ls graceful-fs

├─┬ gulp@3.9.1
│ └─┬ vinyl-fs@0.3.14
│   └── graceful-fs@3.0.8 
└─┬ gulp-sass@1.3.3 invalid
  └─┬ node-sass@2.1.1
    ├─┬ gaze@0.5.2
    │ └─┬ globule@0.1.0
    │   └─┬ glob@3.1.21
    │     └── graceful-fs@1.2.3 
    └─┬ pangyp@2.3.3
      ├─┬ fstream@1.0.9
      │ └── graceful-fs@4.1.4 
      └── graceful-fs@3.0.8 

Someone have already faced this problem before? Any ideas?