Ionic run android doesnt start

I was trying to test my app on android , But the Ionic run android doesnt start . What is the reason ?? Please help .?

Hi, we’ll need a bit more information:

  1. What error message(s) are you getting?
  2. Which OS are you running?
1 Like

I have a Galaxy S4 GT-I9505 running Android 4.3 . Im not getting any error messages . It displays:

Running run task
Running app on platform android

And then I should wait . It either ends after some time or doesnt respond .

This happened to me as well a while back. Unfortunately I do not completely remember what fixed it - I thought it could be a problem with the Android SDK I downloaded (first time I’d tried Android development on the Mac).

Did you try running it on the emulator? Did that show any errors or did a while back?
What is your host OS (of computer)?

Did you have cordova installed previously? Its possible that a previous npm global install may be affecting this.

Suggestion - can you try an:

npm -g uninstall generator-angular

This has affected some of my AngularJS project builds in the past, notably SASS+Compass compilation.

And then the usual:

ionic platform android
ionic emulate android

What happens when you try this?

The problem was with the SDK . I was earlier using the old version 2.0 or some . Deleted it and trying to work with the new . Thankuu…

i am having the same error , please help asap!!

Check the version of the android sdk you have setup . Phonegap requires Android 4.2 or above . I deleted all that I had and downloaded a new bundle from developers.android.com . Try that

1 Like

Exactly the problem was there in sdk … i did the same as u said…worked fine (y)…Thanks alot.

(sighs) just encounter another problem :frowning: …now the error is unable to find javac , even though i have install JDK and set PATH variable also correctly.???

just my experience with the same issue, and i did struggle :smile: if it helps someone please take it …
i ran only the run command -

ionic platform android
ionic run android

later realised that i should have run the platform command first.

not sure if i missed somewhere … didnt find the platform command in this page … http://ionicframework.com/docs/guide/testing.html (moderator attention may help)