Ionic Pro live deploy. On relaunch app rolls back to binary version


#1

Hey, I’m using Ionic Pro’s Live Deploy feature to deploy iOS app, with ‘auto’ setting to download new version on splash screen.
I’m having a behavior where app rolls back to a binary version of the app when I relaunch it

For example,
Currently, a user has an app with version 1.1 and I want to deploy a new version of the app (v1.2)
Reproduce steps:

  1. Deploy new build (v1.2) in ionic dashboard
  2. Kill the app and reopen -> app is on v1.2 (correct)
  3. Kill the app and reopen -> app is on v1.0 (original binary version)
  4. Kill the app and reopen -> app is stuck on splash screen
  5. Kill the app and reopen -> app is on v1.2 (correct)
    From now on app stays v1.2

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.9.0

System:

ios-deploy : 1.9.2
Node       : v8.9.2
npm        : 5.6.0
OS         : macOS Sierra
Xcode      : Xcode 9.2 Build version 9C40b

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

Live Deploy Suddenly Stopped
#2

Can we bump this up? I’m running into the exact same issue. @olehkolinko Did you ever find a solution?


#3

Hey, I contacted ionic support for this, they was able to reproduce the issue and they opened a ticket with the deploy team. Right now I don’t have any solution but I will update as soon as I have some news.


#4

@olehkolinko Curious, have you tried downgrading app-scripts to 2.1.4? Maybe it’s related to their live reload issues


#5

I haven’t tried it, for my case I will have to change a lot of codebase for downgrade. Did downgrade fixed your issue?


#6

Nope, tried downgrading, it did nothing :frowning:

I have your exact behavior with cordova-plugin-ionic-webview 1.1.16. Then when I upgrade to 1.2.0, it doesn’t event apply in the first place. Something is off here