Ionic + phonegap ( NOT cordova) give errors in installation does it even support phonegap?


#1

i installed the phonegap + nodejs + all that is needed to make it work and it works great
now i like to install the ionic framework and use it in phonegap project but with no success.
i think its still looking for cordova .
what shell i do if i like to use it in phonegap ?
this is the error im getting while trying to Scaffold my First Ionic App

D:\dev\Mobile\PhoneGap>ionic start myFirstIonicApp
Creating Ionic app in folder D:\dev\Mobile\PhoneGap\myFirstIonicApp based on tabs project

Downloading: https://github.com/driftyco/ionic-app-base/archive/master.zip
[=============================]  100%  0.0s

Downloading: https://github.com/driftyco/ionic-starter-tabs/archive/master.zip
[=============================]  100%  0.0s

Update config.xml
Initializing cordova project
'cordova' is not recognized as an internal or external command,
operable program or batch file.
Unable to add plugins. Perhaps your version of Cordova is too old. Try updating (npm install -g cordova), removing this project folder, and trying again. (CLI v1.2.8)