Ionic Package Build Fails Error: Cannot find module 'plist' (Solved)


#1

Not sure what to make of this, some projects I am working with still build fine, just one that uses the cordova-plugin-settings-hook does not. Can’t figure out why.

global packages:

@ionic/cli-utils : 1.4.0
Cordova CLI      : 7.0.1
Gulp CLI         : CLI version 3.9.1 Local version 3.9.1
Ionic CLI        : 3.4.0

local packages:

@ionic/cli-plugin-cordova : 1.4.0
@ionic/cli-plugin-gulp    : 1.0.1
@ionic/cli-plugin-ionic1  : 1.3.0
Cordova Platforms         : android 6.2.3
Ionic Framework           : ionic1 1.3.1

System:

Node       : v6.11.0
OS         : Windows 10
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed
npm        : 5.0.3

#2

I have the same problem. It looks like a problem with version 0.2.6 which made changes related to plist. Reverting the versoin to 0.2.5 in config.xml solves the problem for me. I created an issue on GitHub: https://github.com/mircoc/cordova-plugin-settings-hook/issues/13


#3

There was activity on that Github issue:
https://github.com/mircoc/cordova-plugin-settings-hook/issues/13#issuecomment-312885209


#4

The new version 0.2.7 of cordova-plugin-settings-hook that the author very swiftly released today solves this problem for me!


#5

Thanks for bringing it to their attention, this fix for worked for me as well.