Ionic New Project start error - "Not Authorized: Missing Rule:"


#1

Since the start, I keep seeing that creting a new project fails…
PS C:\Users\admin> ionic -v
3.19.0
PS C:\Users\admin> ionic start --pro-id 6bac7763
Request: GET https://api.ionicjs.com/apps/6bac7763
Response: 403
Body:
{ message: ‘Not Authorized: Missing Rule: apps:app_id:ReadApp’,
link: null,
type: ‘PermissionError’ }
PS C:\Users\admin> node -v
v9.0.0
PS C:\Users\admin>
image


#2

Run ‘ionic info’ and post the output.


#3

As it says, you are not authorized, mean this request is not identified. have you gone thru the SSH Key pairing between your computer and Ionic?


#4

Thanks for the quick reply. Here is what I get:
PS C:\Users\admin\ionic> ionic info
[WARN] You are not in an Ionic project directory. Project context may be missing.

cli packages: (C:\Users\admin\AppData\Roaming\npm\node_modules)

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

System:

Node : v9.0.0
npm  : 5.5.1
OS   : Windows 10

Misc:

backend : pro

PS C:\Users\admin\ionic>


#5

The getting started steps do say I need to and I saw doc that said SSH keys are added by the Ionic start automatically. (Ref:https://ionicframework.com/docs/pro/basics/git/#ssh-keys)

I realised GIT was not installed, so installed it, restarted the windows CLI, but I get same error still.


#6

Have you tried logging in using ionic login ?


#7

I relaised I was logged in with a different user and your idea on login worked as I logged in to the correct account,. Thanks…


#8

Great :slight_smile: