IONIC EMULATE IOS NOT WORKING - Error: EACCES: permission denied, open '/Users/abimunoz/.config/configstore/insight-cordova.json'


#1

I created a project with Iconic Creator and exported it with the Ionic CLI Tool. The project seems to be working as I can run it on a browser with the command IONIC SERVE. However, when I try to run the command IONIC EMULATE ISO the following message appears:

urbanParadise ionic emulate ios
/usr/local/lib/node_modules/cordova/node_modules/insight/node_modules/configstore/index.js:53
throw err;
^

Error: EACCES: permission denied, open '/Users/abimunoz/.config/configstore/insight-cordova.json’
You don’t have access to this file.

at Error (native)
at Object.fs.openSync (fs.js:549:18)
at Object.fs.readFileSync (fs.js:397:15)
at Object.create.all.get (/usr/local/lib/node_modules/cordova/node_modules/insight/node_modules/configstore/index.js:34:26)
at Object.Configstore (/usr/local/lib/node_modules/cordova/node_modules/insight/node_modules/configstore/index.js:27:44)
at new Insight (/usr/local/lib/node_modules/cordova/node_modules/insight/lib/index.js:38:34)
at Object.<anonymous> (/usr/local/lib/node_modules/cordova/src/telemetry.js:37:15)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)

How can I fix this? Thank you!!


#2

Hey, I had the same error.
See the following link, there I got the solution.
https://github.com/bower/bower/issues/2262


#3

Hello use this command :
sudo chown -R $USER:$GROUP ~/.npm
sudo chown -R $USER:$GROUP ~/.config.
It resolve mine.


#4

When I run sudo chown -R $USER:$GROUP ~/.config.
chown: /Users/abhinav/.config.: No such file or directory
Even I’m unable to create ./config file under abhinav user manually.


#5

the command is

sudo chown -R $USER:$GROUP ~/.npm
sudo chown -R $USER:$GROUP ~/.config

remove the last dot(.) from chown -R $USER:$GROUP ~/.config.