Ionic DevApp Feedback Mega-thread

#165

In addition to typing in the ip address and port manually, DevApp should include a way to point the camera at your screen and connect. (Obviously, I’m having problems getting with the auto-discovery… using iOS, home WiFi, Mac)

IMG_7407

#166

I can’t find my App in the DevApp too. When i connect the laptop with my mobile hotspot everything worked fine, but in my office wlan it doesn’t. I tried to add a rule to inbound rules of windows-firewall, but this doesn’t work either.
Entering the Address manually causes a long white screen and then a “Failed to load” Error.
Any Ideas?^^

#167

Did anybody observe, that when you make a Ionic4 & Angular6 Project, that the devApp is starting fine, but it returns a error regarding the vendor.js. The error is “use of const in strict mode”.
Maybe somebody got an answer?

To reproduce start a project ionic and angular6 project from scratch.

Then try to run on devapp.

Greets!

#168

where? I have similar issue. can you help me out?

#169

I have similar issue. It’s not my own web services. I can not modify that. so, is there any way to solve this problem
?

#170

You will have to add your local API to your backend API CORS configuration as an allowed origin. I was using php with Laravel and they had a CORS package to configure it. If you are using other languages it should have something similiar

Outlook til iOS

#171

Please add following preference to the config.xml

<preference name="AllowInlineMediaPlayback" value="true" />

In my use case, my app is using HTML5 <video> Tag and on IOS Devices the Video will always play’s in Fullscreen without this setting.

#172

Hi, the remote devices from Chrome console is still unavailable with Ionic DevApp ?

#173

Hello,

App freeze after starting on network check … dont know how I can retrieve some logs or something to forward @ionicteam to help

#174

Cordova plugin not working in ionic DevApp. I have installed https://ionicframework.com/docs/native/image-picker/ this plugin … it is working fine when build but not with ionic serve -c and see in the DevApp

It’s giving below error in console -

[app-scripts] [00:51:38]  console.warn: Ionic Native: tried calling ImagePicker.getPictures, but the ImagePicker plugin is not 
[app-scripts]             installed. 
[app-scripts] [00:51:38]  console.warn: Install the ImagePicker plugin: 'ionic cordova plugin add cordova-plugin-telerik-imagepicker' 

#175

+1 for this issue but for some reason on android only not iOS

#176

I installed DevApp and I love it to bits. It however doesn’t seem to run cordova plugins and I cannot get it to capture console logs. I am using ionic serve-c to run it.

#177

It does, but only a specific list: https://ionicframework.com/docs/appflow/devapp/#native-cordova-plugin-support

#178

I read that before. I am trying to use the emailComposer which it supports.
Here are my Angular code snippets.

#179

I just started trying out the DevApp and discovered an issue that I haven’t been able to sort out. I’ve made sure any extraneous networking related stuff is disabled, killed Team Viewer, etc, but the app simply shows “Listening for apps on your network” constantly.

Interestingly, if I go to directly add the ip address it works just fine, so it’s definitely not an issue with the device and computer not being on the same network or something.

Honestly, even if the app would just remember the last ip/port you typed in not having the discovery feature working wouldn’t even be that big of an issue :slight_smile:

2 Likes
#180

I can only confirm that kind of issue. Mac OS X, Ionic Framework 3 with DevApp with no problems at all. After upgrade to Ionic 4 I am not able to connect to Mac from DevApp. I also tried to enter IP manually and it seems I have workaround for now, because in that case everything works…

#181

Same issue: app not discovered, but I’m able to use the “Enter address manually” function. Thanks for this great tool!

#183

I have a problem with the design of my application.Ever since the update of the Ionic DevApp to work with Ionic 4 my application’s design just messed up. White text appear black and the general design just changes but this only happens if I run my application from Ionic DevApp. After that it doesn’t matter if I reinstall the app even from the PlayStore the app stays like that on that certain phone. I can update the app and it just works fine in any other device as long as I don’t run it with Ionic DevApp.

Device: OnePlus 6
Android Version: 9.0

#184

same issue here - Ionic 4 - running on Ubuntu.

#185

same problem here. App is not listening. All Ports are allowed in my Firewall and if I type in my Adress directly it works. Ionic 4