Ionic DevApp Feedback Mega-thread


#84

Hi Thank you for the great app.

My application is working well on DevApp, Native plugin like camera, rate, in app browser are good on my Iphone 6 10.3.3 but Contacts plugin is not working. I saw this plugin in the list plugin available but on my Iphone it always show "console.warn: Install the Contacts plugin: ‘ionic cordova plugin add cordova-plugin-contacts’ "

Thank you.


#85

Hello ionic community

I want to debug apps in DepApp on the go at different locations with restricted wifi. For example https://www.eduroam.org/ which is commonly at airports wont let me see the app in ionic devapp when i am serving.

Do you think devapp could work if i connected to a public wifi like eduroam using a second wifi adapter? For example this one: https://www.netgear.com/support/product/WNA3100M.aspx

Thanks


#86

When I did ionic serve
this is what I get:

today 9 Nov 17 I uninstalled ionic and cordova, cleaned cache and reinstall them again.

When I ran ionic serve the app opened fine in the web browser. When I started Devapp it detected my appand when I touched may app to view it this is what I get again:

Any help to fix is much appreciated.


Today SundayNov 12 17:

I started a new project using the Super starter for ionic V3.
When I run ionic serve… it opened well in my Firefox browser. The super starter was perfect. But when I tried to run it on my Android phone this is what I get:


#87

This app is a really great idea, but we really need cordova-plugin-file support. We make heavy use of this plug in to manage files on the device, and without it, this app doesn’t help us much. For example, our app copies images taken with the camera to a folder for later manipulation. We manage lots of local JSON files that are edited by the app. Seems like file system access is such a basic thing, is there a reason it wasn’t included? Are we missing something by using it? Is there an better alternative?


#88

ionic serve --local was broken by ionic for those of use that stayed at 3.16.0, now i get to be spammed by devapp not found because i can’t use --local anymore


#89

@Ben1nB1ack --local only loads localhost for me. No devapp server found.
ionic serve - ERR_CONNECTION_TIMED_OUT

Were you able to find a fix.


#90

not for 3.16.0, 3.18.0 came out so i went to that.


#91

Works great for me. Sometimes it gets into a loop where it’s endlessly searching for my app on the network and I have to shut down the devapp and open it again and then it finds it.


#92

I also upgraded to 3.18.0. Still --local loads only localhost on desktop. Nothing for devapp.
Here is my ionic info output

$ ionic info
[WARN] Error with .\www\lib\ionic\version.json file: FILE_NOT_FOUND, trying .\bower.json.

cli packages: (C:\Users\sd0003\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.18.0
    ionic (Ionic CLI) : 3.18.0

global packages:

    Gulp CLI : CLI version 3.9.1 Local version 3.9.1

local packages:

    Ionic Framework : ionic1 1.3.4

System:

    Node : v8.9.1
    npm  : 5.5.1
    OS   : Windows 10

Misc:

    backend : pro

#93

The devapp crashes while showing the splashscreen every time i open it on my ipad 4.
I have iOS 9.2.1(13D15) , 16gb and I don’t want to upgrade to IOS 10.
Any Ideas why it doesn’t work? and/or could you fix that in the next update?


#94

I get these errors when running devapp on ios:

console.log: deviceready has not fired after 5 seconds.
console.log: Channel not fired: onDOMContentLoaded
console.log: Ionic Native: deviceready event fired after 2881 ms

$ ionic info:

cli packages: (/Users/Flare/.nvm/versions/node/v8.9.0/lib/node_modules)

@ionic/cli-utils  : 1.18.0
ionic (Ionic CLI) : 3.18.0

global packages:

cordova (Cordova CLI) : 7.1.0 
Gulp CLI              : CLI version 3.9.1 Local version 3.9.1

local packages:

@ionic/app-scripts : 3.0.1
Cordova Platforms  : ios 4.5.2
Ionic Framework    : ionic-angular 3.8.0

System:

ios-deploy : 1.9.2 
Node       : v8.9.0
npm        : 5.5.1 
OS         : macOS High Sierra
Xcode      : Xcode 9.1 Build version 9B55 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

#95

I’m having the same issue with the Contact plugin, did you find a way to make it work?


#96

I am using new Ionic View to test the app. The contact plugin is working well in Ionic View app. :smiley:


#97

Hey all, as has been noted a few times in here, the --local flag to ionic serve will make the DevApp not work. That flag binds serve to your loopback device (127.0.0.1) which makes it impossible to access that server from a different machine.

If you want to use DevApp, don’t use that flag.


#98

Having network/possibly CORS(?) issues using firebase+facebook social login. Error below.

asd


#99

Where do you add this? Does social/facebook login work for you?


#100

To my own API server which is php with Laravel Framework and I installed a package to handle CORS

Få Outlook til iOShttps://aka.ms/o0ukef


#101

I tried running the app on my Samsung Galaxy S5 and it crashes on the splash screen with the message: “Unfortunately, Ionic DevApp has stopped.” What could the problem be?


#102

Is the geofence plugin on the roadmap for inclusion in DevApp?


#103

I’m not seeing my app show up in the DevApp. I’m on the most recent CLI (3.18.0) and on the same network for both the PC and phone (iOS 11). I have force quit the DevApp and re-ran ionic serve. Nothing I’ve done seems to make this work. Am I missing something? Is there a plugin I need to enable for this to work? I’m just using the tabs template as the starter and been building off that. Any help would be much appreciated!