Ionic DevApp Feedback Mega-thread

I’ve found that that built-in values such as [externalRootDirectory] are null
JC

Is there any way to get this worked in the iOS simulator? (I know: we can’t install apps, unless there is an .app or xcode file to load it…)

Hi, this doesn’t seem to work too well for me (or maybe I’m misunderstanding what the limitations are). However, I cannot get an app, which normally runs happily on an iOS device and simulator to get past the “cordova_not_available” part of

ionic serve -c

This is in both Ionic DevApp AND building to Ionic View. Any ideas?

Hi, I also have the same problem. Getting the error that the plugin is not installed when calling the contacts find method. Iphone 6 with ios 10.1.1. Have you found any way to get it to work? Thanks!

Hi,
Thanks for the great app for developers. I would like to know, whether the Inappbrowser functionality is working?.

Interesting, so more or less a ionic cordova run --livereload that uses an app from ionic serve instead of what was built into it… That would mean it would have to include code to “receive” the running ionic serve instances instead of the real www.

Hmm, that should be doable with a little local scripting. Only thing missing is the code of the DevApp that displays the instances (and all workarounds so it can “just” display these then - but I am not sure if there are any).

Want to create a new topic for this “Local DevApp: Mix ionic cordova run --livereload with ideas from the Ionic DevApp” thing you just invented? I think we should talk about it some more @Tommertom.

Edit: I remembered that someone created a project on Github with a “build your own DevApp with your own plugins”. I am pretty sure one could reuse that code…

Edit 2: Local DevApp: Mix `ionic cordova run --livereload` with ideas from the Ionic DevApp :wink:

2 Likes

Thx for the reply and yes, it will be interesting to venture a bit. I see three things here:

The product roadmap for the Ionic DevApp - how this fits the needs of the dev community. If I were the product manager, I would have the DevApp run the same plugins as Ionic View and add a feature to manually add ionic serve instances (as corporate networks tend to block udp discovery which I presume is used to discover). And I would launch boilerplate code on GitHub with necessary plugins which developers can use to generate own devapps with custom plugin configuration. This way, indy and more corporate developers are supported and flexibility added for people with additional support needs, including monitoring console.logs etc.

The community figuring out its own devapp - and indeed that is what I tried earlier (and posted in the forum). And it seemed to work on the vibration plugin. But not with another simple plugin (Device), due to absence of cordova.js etc. Seems that a navigation redirect kills the cordova connection. So I would love to hear suggestions on how to fix this. I tried InAppBrowser injection and possibly look into other features… Suggestion in the other thread please!

Ionic releasing a CLI version as expressed - making all the above actually quite obsolete. That would really a blast to have, especially if Ionic team next to it does provide the DevApp in the appstore for the indy developers who don’t need all that flexibility (or even use it for other purposes).

Anyway… some of my thoughts, also going through the messages in this mega thread.

Regards

Tom

2 Likes

I have the same issue at the moment. I can’t seem to find a fix for this. Did you find a solution to the problem?

I haven’t tried since, I’m almost 100% sure it has to do with the use of some cordova plugins that aren’t included in the app, and in my case I’m using at least one plugin that isn’t wrapped in ionic native. With that in mind I think it’s impossible for it to work in my case.

I note that a number of developers have asked about the plugins included in the DevApp.

The Ionic team has been kind enough to include the link to the plugins for the Ionic View App which are replicated in the DevApp.

Personally, I would often forget to check this list as I added cordova plugins during development and then end up with an app that would not boot in the DevApp, or would throw an error when a function dependent on cordova plugin(s) not included was called.

To resolve this, I created a pull request on the ionic-cli package that will add a warning whenever an unsupported cordova plugin(s) is found in your package.json when ionic serve is run.

4 Likes

Awesome work @jwelmac - makes total sense to do it there!

I’ve tried Ionic DevApp a couple of times with different wifi sources. I’ve never been successful at connecting an app to DevApp. I am running the latest version, using the same wifi sources, running ionic serve -c. It cannot detect any app running on the network. I was really excited for this but neither me nor my coworker can use it. :disappointed:

@GC46001 Can you manually open the external IP that ionic serve shows in your smartphone’s browser?

Along with what @Sujan12 said, are you on a corporate network?

1 Like

@Sujan12 It just sits there and loads but I need to try on another network at the end of the day. @max I am on a corporate network but when I first started testing DevApp a few weeks ago I was using my personal network. Today I tested on our guest corporate network which doesn’t usually cause problems, but I think it might be causing problems now.

As for the network I initially tested, it is a college owned network. I’ve never had issues using it with ionic, but could it be causing the issue as well?

1 Like

Yep, corporate and “shared” networks like campus networks tend to not allow connections between networked machines. You should try on a normal home network - these tend to be more open. Also see if you can check any boxes in your OS network settings for the network you are in, often this can also be configured.

Ah. That’s unfortunate. Thanks for clearing things up.

Just figured out that a simple javascript alert is not working on iOS and crashes the complete DevApp, Android it does.

alert("this is my function");

Anyone else seeing this?

I have the same issue, I am able to open the external link, but i cannot use devApp to see it in both Android and iOS, what else can i try? I followed all the instructions and watched ionic docs videos.

Im confused, why don’t you use AlertController