Ionic cordova requirements

Hi all, my mac configuration:

System:
Android SDK Tools : 26.1.1 (/Users/mauro/Library/Android/sdk/)
ios-sim : 7.0.0
NodeJS : v10.15.0 (/usr/local/bin/node)
npm : 6.7.0
OS : macOS Mojave
Xcode : Xcode 10.1 Build version 10B61

Running cmd: “ionic cordova requirements” i’ve this:

Android Studio project detected

Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: installed android-28,android-27,android-26
Gradle: installed /usr/local/Cellar/gradle/5.1.1/bin/gradle

Requirements check results for ios:
Apple macOS: installed darwin
Xcode: installed 10.1
ios-deploy: not installed
ios-deploy was not found. Please download, build and install version 1.9.2 or greater from https://github.com/phonegap/ios-deploy into your path, or do ‘npm install -g ios-deploy’
CocoaPods: installed 1.5.3
Some of requirements check failed

Is it normal ?
Thanks for help

Hi @blondie63 :wave:

What do you mean by normal? Your Android requirements look ok, but if you want to build your app for iOS you should install ios-deploy with npm install -g ios-deploy as suggested.

Best,
Rodrigo

i discovered that i’ve no ionic-deploy installed and install need two special flags…
sudo npm install -g ios-deploy --unsafe-perm=true --allow-root

now it’s ok, thanks

I’m glad you found the problem! I think you can mark your own answer as the solution, in case somebody else runs into the same problem :wink:

1 Like