Ionic cordova build android error help mee


#1

ionic cordova build android

Help me please


#2

What is your package.json? Might want to remove the node_modules folder and reinstall with ‘’‘npm install’’’


#3

{
“name”: “app1”,
“version”: “0.0.1”,
“author”: “MtBB”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
"@angular/common": “4.1.2”,
"@angular/compiler": “4.1.2”,
"@angular/compiler-cli": “4.1.2”,
"@angular/core": “4.1.2”,
"@angular/forms": “4.1.2”,
"@angular/http": “4.1.2”,
"@angular/platform-browser": “4.1.2”,
"@angular/platform-browser-dynamic": “4.1.2”,
"@ionic-native/background-mode": “^3.11.0”,
"@ionic-native/calendar": “^3.12.1”,
"@ionic-native/core": “3.10.2”,
"@ionic-native/local-notifications": “^3.11.0”,
"@ionic-native/network": “^3.11.0”,
"@ionic-native/push": “^3.11.0”,
"@ionic-native/splash-screen": “3.10.2”,
"@ionic-native/sqlite": “^3.12.1”,
"@ionic-native/status-bar": “3.10.2”,
"@ionic/cloud-angular": “^0.12.0”,
"@ionic/storage": “2.0.1”,
“angular-calendar”: “^0.17.0”,
“cordova-android”: “^6.2.3”,
“cordova-ios”: “^4.4.0”,
“cordova-plugin-app-event”: “file:node_modules/cordova-plugin-app-event”,
“cordova-plugin-background-mode”: “^0.7.2”,
“cordova-plugin-calendar”: “^4.5.5”,
“cordova-plugin-compat”: “^1.1.0”,
“cordova-plugin-console”: “^1.0.5”,
“cordova-plugin-device”: “^1.1.4”,
“cordova-plugin-extension”: “^1.5.1”,
“cordova-plugin-network-information”: “^1.3.3”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.2”,
“cordova-plugin-whitelist”: “^1.3.1”,
“de.appplant.cordova.plugin.local-notification”: “^0.8.5”,
“ion2-calendar”: “^1.0.7”,
“ionic-angular”: “3.3.0”,
“ionic-native”: “^2.9.0”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“moment”: “^2.18.1”,
“phonegap-plugin-push”: “^1.10.4”,
“rxjs”: “5.1.1”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.11”,
“cordova-plugin-admob”: “^2.29.0”,
“cordova-plugin-admobpro”: “^2.29.0”
},
“devDependencies”: {
"@ionic/app-scripts": “1.3.7”,
"@ionic/cli-plugin-cordova": “1.3.0”,
"@ionic/cli-plugin-ionic-angular": “1.3.0”,
“typescript”: “2.3.3”
},
“description”: “Bir mtbb projesidir.”,
“cordova”: {
“plugins”: {
“cordova-plugin-console”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-whitelist”: {},
“ionic-plugin-keyboard”: {},
“cordova-plugin-network-information”: {},
“de.appplant.cordova.plugin.local-notification”: {},
“cordova-plugin-background-mode”: {},
“cordova-plugin-calendar”: {
“CALENDAR_USAGE_DESCRIPTION”: " "
},
“cordova-plugin-admobpro”: {},
“cordova-plugin-admob”: {}
},
“platforms”: [
“android”,
“ios”
]
}
}


#4


#5

Looks like the npm install removed the type errors, but now you have Cordova errors, could you copy the output after ’ $ ionic info ’ ?


#6

What is the problem ?


#7

Stop posting screenshots of text. Post the actual text as text.

You should upgrade to Ionic Native v3.


#8

Do not look at the picture I thought it would be more understandable.I upgrade to the official v3 will correct my problem? And how can I rise?


#9

Did he work before, would not he be desperate without ascension?


#10

You upgrade the same way you upgrade any other package, with npm or editing package.json. Documentation on how to use v3 is here. It requires some changes to your code, but it is worth it because your app binary will get considerably smaller.


#11

Are you saying to upgrade to the best v3?


#12

But when I upgrade to v3, I get an error like this:
npm WARN @angular/animations@4.2.2 requires a peer of @angular/core@4.2.2 but none was install
ed.


#13

That is a warning, not an error. Also it can easily be fixed by installing the animations package if you don’t like the warning.


#14

I’m not sure that would solve that warning. The way I read it, one would have to either pin animations to match the version of core, or update core to 4.2.2 to match animations.