Ionic CLI ignoring flags/parameters


I think I have an installation problem on a new MacBook set up. I have installed all prerequisites, and I receive no CLI errors when running commands; cordova create seems to execute fine and I can run the HelloCordova project which is set up by default fine.

But, when I run ionic start, it’s ignoring the parameters I pass via CLI flags; and I have no idea why!

As an example, I run:

ionic start -a MyApp -i ionic-app blank

ionic-app directory is created, and it configures the correct starting template. However, the app name nor the app ID is set to the parameters I set. I have also tried:

ionic start -a "MyApp" -i ionic-app blank

No joy. I cannot figure out for the life of me what is wrong. This is the output when I do run the command:

Creating Ionic app in folder /Users/kelvindart/Desktop/ionic-app based on blank project
[=============================]  100%  0.0s
[=============================]  100%  0.0s
Updated the hooks directory to have execute permissions
Update Config.xml
Initializing cordova project
Adding in iOS application by default

I execute ionic build and that runs fine. Yet this is the result of Xcode when I open the xcodeproject file created in platforms/ios/ionic-app:

Any ideas why this is not fully configuring the project as it should be?

I have tried everything. Uninstall node/cordova/ionic, deleting directories ~/.cordova and ~/.ionic, yet no joy.

If anybody can shed any light on this, I’d greatly appreciate it.

I’m running:
Mac OS X El Capitan 10.11.1
Xcode 7.1.1


This is Node v5 related - having rolled back to v4.2.3 the command executes fine, with the supplied parameters creating a project with the app name, and package ID as expected!