Ionic Cli 4.0.0 Update - Will it break my Ionic 3 app

#1

Really excited about the new Ionic 4.0.0 released. However before I plunge myself into it I would like to wait for the beta phase to be completed. The question I have is when I do ionic serve, it asks if I want to upgrade my Ionic Cli from 3.20.0 => 4.0.0. I am assuming if I do this upgrade my app will break as it will need to be migrated to 4.0.0 standards, is this right?

#2

No. Ionic CLI and Ionic Framework are two different things.

Ionic CLI 4.x supports all Ionic Framework versions, from v1 up to the new v4 beta.

#3

Great thanks for clarifying :slight_smile:

#4

Some more information on that by the way: