Ionic capacitor run android --list cant find devices

I had the same issue and after upgrading Android Studio to “Arctic Fox | 2020.3.1”, when loading the project on Android Studio, it asks for updating the Gradle version of my project and after upgrading, my device was able to be shown on the list.

In my case I forgot to add JAVA_HOME and ANDROID_SDK_ROOT environment variables. After adding a valid path it starts working perfectly.

Close chrome debugger as well as chrome://inspect tab.

In my case I notice the command:

npx native-run android --list --verbose

I don’t have installed the apiLevel packs 28 and 29.

  native-run:android:utils:avd:getDefaultAVDSchematic Issue with API 29: Unsatisfied packages within API 29: platforms;android-29 +0ms
  native-run:android:utils:avd:getDefaultAVDSchematic Issue with API 28: Unsatisfied packages within API 28: platforms;android-28 +0ms

I installed this and everything is working.

3 Likes

I’ve noticed a conflict here as well. Previously I’ve used cordova and had ANDROID_ROOT_HOME set, once I had updated that environment variable to ANDROID_HOME, capacitor picked up the devices.

After update capacitor/cli not working properly. Note that I updated project dependencies and Android Studio (not sure in which order).

The issue is that ionic capacitor run android --target=X and ionic capacitor run android --list do not run, just opening project in Andorid Studio IDE. I cannot run app in my mobile device.

Note that mobile device is listed on npx native-run android --list

I had the same error, ionic cap run --list android , I couldn’t find the emulator, it was solved by downloading the versions of Android 11 and Android 13 from the Sdk Manager

I install android SDK manually then following command work

C:\android\cmdline-tools\latest\bin>avdmanager list device

Also created a demonstration at
//Ionic 6 Angular - How do I make a APK without Android studio. Part 2 - installation of SDK - YouTube

I had the same issue on linux
[FIXED]:

export ANDROID_HOME=$HOME/Android/Sdk
ionic cap run android -l --external

Make sure you have android sdk on your home dir

1 Like

Hi, I had the same problem here and everything seemed to be correctly configured. In fact, everything was! The problem was I was not running the ionic capacitor run android --list from the project root folder. I was in an inner component folder in the terminal. By going back to the root project folder and running the ionic capacitor run android command again, it worked!

Hi man, man the same as you. I’m using Linux (Ubuntu 20.04 to be specific), this is my environment:

Node.js 16.18.0
Ionic 7.0.1
Angular 15
Java 11
Android Studio Electric Eel (SDK’s 9, 10, 11, 12, 13)

Ionic throws an error when executing “ionic capacitor add android” or “ionic capacitor run android”: [Error] no devices or emulators found

I tried adding JAVA_HOME, ANDROID_SDK_ROOT to .bashrc, but finally ir worked when I added ANDROID_HOME.

For those who want to do it, this is what I did:
nano ~/.bashrc

JAVA_HOME=/usr/lib/jvm/java-11-openjdk-amd64
ANDROID_HOME=$HOME/Android/Sdk
ANDROID_SDK_ROOT=$HOME/Android/Sdk

export JAVA_HOME
export ANDROID_HOME
export ANDROID_SDK_ROOT
export PATH=$PATH:$JAVA_HOME/bin
export PATH=$PATH:$ANDROID_SDK_ROOT/tools
export PATH=$PATH:$ANDROID_SDK_ROOT/platform-tools
export PATH=$PATH:$ANDROID_SDK_ROOT/emulator

source ~/.bashrc

Test:
echo $JAVA_HOME
echo $ANDROID_HOME
echo $ANDROID_SDK_ROOT

For me it was a complete abstract reason. Took me hours to find out:

I have Native Instruments Audio Plugins installed on my computer. Native Instruments installs a Updater Daemon which is running on port 5562. This is detected from adb as emulator. And capacitor run android --list does not work anymore if this emulator is detected by adb.

More infos here:

I just had to stop the Native Instruments service, then everything works