Ionic capacitor run android device -- No Java Runtime

I’m running into a peculiar error… attempting to run

ionic capacitor run android --device --prod --verbose… selecting my device from the list,

but I get an error message that the Grable build failed as my tablet does not have a Java Runtime.

This is a Samsung Galaxy Tablet A7… so the guidance to go install java from java.com is not overly helpful.

Any one have any insight on how to overcome this?

I don’t think it means that your tablet doesn’t have a Java Runtime but the computer where you run the command.

well… I feel silly now…