Ionic Appflow - cannot create new package


#1

Just started using the Growth version of Ionic Appflow and I am having issues setting up my application. I have a private repo on Github that I have connected to Ionic Appflow in several ways, all of which do not allow me to create a package build. First I set it up via Github but when I went to create a package build it told me to “Connect your app to Ionic Appflow”. This routes me to Settings > Git where it says my app is connected. Eventually I disconnected the app and used ionic link which ended up in the same result. I tried relinking as well but still no luck. My ionic CLI is at latest (4.6.0) and I have certificates set up under Package > Certificates. Also, Deploy has the exact same behavior. I have exhausted everything I can think of so it would be a big help if anyone has any information. Thanks.


#2

I figured out my issue. It seems Ionic Appflow is not convinced that your app is connected until your 1st commit after connecting to Appflow. This did not seem very obvious to me but if you are hooking up a preexisting app to Appflow then you will need to make some sort of commit before it is recognized.