Ionic 4.4 update, ionic serve not found command


#1

when update ionic 4.3 to 4.4 ionic serve not working, and show me ionic


#2
$ ionic info

global packages:

    @ionic/cli-utils : 1.4.0
    Cordova CLI      : 6.5.0
    Ionic CLI        : 3.4.0

local packages:

    @ionic/app-scripts              : 1.3.7
    @ionic/cli-plugin-cordova       : 1.4.0
    @ionic/cli-plugin-ionic-angular : 1.3.1
    Cordova Platforms               : android 6.1.2
    Ionic Framework                 : ionic-angular 3.3.0

System:

    Node       : v6.11.0
    OS         : Windows 10
    Xcode      : not installed
    ios-deploy : not installed
    ios-sim    : not installed
    npm        : 3.10.10

The latest version of the Ionic CLI is 3.4.0. Where’d you get that? jk

Can you check to see if the files ionic and ionic.cmd exist in your npm folder? (It’s usually located at C:\Users\YourName\AppData\Roaming\npm)

EDIT: It would also help if you have the update logs.


#3

yeah today get last version but ionic serve not work for me. ionic.cmd exist here


#4

Ionic 4.4 doesn’t exist, not framework and not CLI. Whatever you installed, it wasn’t Ionic. What command did you run?

Also your output indicated that you have no Ionic CLI installed at all. Run npm install -g ionic to change that.


#5

come back to version 4.3 and fix it


#6

There also is no version 4.3 of Ionic Framework or Ionic CLI.