Ioni error after update 4.3.0


#1

Hi, I’ve a problem after ionic update to 4.3.0
any command insert in the console give this error, even the simple ionic command

events.js:167
throw er; // Unhandled ‘error’ event
^

TypeError [ERR_INVALID_ARG_TYPE]: The “chunk” argument must be one of type string or Buffer. Received type object
at validChunk (_stream_writable.js:258:10)
at WriteStream.Writable.write (_stream_writable.js:292:21)
at process. (/Users/stefanotoppi/.npm-global/lib/node_modules/ionic/bin/ionic:9:63)
at process.emit (events.js:182:13)
at emitPromiseRejectionWarnings (internal/process/promises.js:119:20)
at process._tickCallback (internal/process/next_tick.js:69:34)
at Function.Module.runMain (internal/modules/cjs/loader.js:744:11)
at startup (internal/bootstrap/node.js:285:19)
at bootstrapNodeJSCore (internal/bootstrap/node.js:739:3)
Emitted ‘error’ event at:
at validChunk (_stream_writable.js:261:12)
at WriteStream.Writable.write (_stream_writable.js:292:21)
[… lines matching original stack trace …]
at bootstrapNodeJSCore (internal/bootstrap/node.js:739:3)

I’ve try to reinstall old versioni (4.2.1) but not work, always this error.


#2

reinstall ionic 4.3.0.
i was having same issue but after reinstalling my error gone and all cmds working as before


#3

I’ve try but the error persist :frowning:


#4

have u uninstalled ionic before upgrading?


#5

Yes, uninstall ionic and Cordova, and I’ve update node. Probably I’m wrong… which correct commands do I have to reinstall all?


#6

in single cmds
npm i -g ionic cordova

one by one

npm i -g ionic

and

npm i -g cordova

suggestion: You were not having error with Cordova I supposed why u uninstalled.


#7

I’ve tried but nothing…the errors persist…But why if I install the old version still not working ?


#8

after relunch npm i -g ionic cordova the ionic now works!! thanks!