Install ionic error


#1

I installed the last ionic version and can not run ionic serve.
The below is the error message.
Hope your help.Thanks.

  D:\ionic\myApp>ionic serve
Serve.loadSettings - You must pass a project object to pull out project specific
 settings from

Error: Serve.loadSettings - You must pass a project object to pull out project s
pecific settings from
    at Object.loadSettings (C:\Users\eazhou\AppData\Roaming\npm\node_modules\ion
ic\node_modules\ionic-app-lib\lib\serve.js:153:11)
    at Object.IonicTask.run (C:\Users\eazhou\AppData\Roaming\npm\node_modules\io
nic\lib\ionic\serve.js:30:23)
    at Object.run (C:\Users\eazhou\AppData\Roaming\npm\node_modules\ionic\lib\cl
i.js:71:32)
    at Object.<anonymous> (C:\Users\eazhou\AppData\Roaming\npm\node_modules\ioni
c\bin\ionic:13:10)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:929:3

Serve.loadSettings - You must pass a project object to pull out project specific
 settings from (CLI v1.4.8)

Your system information:

Cordova CLI: 4.2.0
Ionic Version: 1.0.0-rc.3
Ionic CLI Version: 1.4.8
Ionic App Lib Version: 0.0.23
OS: Windows 7 SP1
Node Version: v0.10.35

#2

I’m getting this same error.


#3

Looks like it was just reported.


#4

Yes, it seems like Ionic 1.4.8 has BROKEN “ionic serve”.

Or we need to be apprised of what the CHANGE is in the command line that requires passing “settings” along with the command.