Information about Ionic dependencies are not located in package.json


#1

I installed a new instance of the tabs app using the ionic version. Ionic -v returns 2.1.8 . The package.json file is

{
  "name": "mps-tester",
  "version": "1.1.1",
  "description": "mps-tester: An Ionic project",
  "dependencies": {
    "gulp": "^3.5.6",
    "gulp-sass": "^2.0.4",
    "gulp-concat": "^2.2.0",
    "gulp-minify-css": "^0.3.0",
    "gulp-rename": "^1.2.0"
  },
  "devDependencies": {
    "bower": "^1.3.3",
    "gulp-util": "^2.2.14",
    "shelljs": "^0.3.0"
  },
  "cordovaPlugins": [
    "cordova-plugin-whitelist",
    "cordova-plugin-statusbar",
    "cordova-plugin-console",
    "cordova-plugin-device",
    "cordova-plugin-splashscreen",
    "ionic-plugin-keyboard"
  ],
  "cordovaPlatforms": [
    "ios",
    {
      "platform": "ios",
      "version": "",
      "locator": "ios"
    }
  ]
}

This seems like it would be an issue when installing plugins that check if peer dependencies are met such as when I tried to do the following

├── UNMET PEER DEPENDENCY @angular/core@*
├── UNMET PEER DEPENDENCY @ionic-native/core@^3.6.0
├── @ionic-native/push@3.6.1
└── UNMET PEER DEPENDENCY rxjs@^5.0.1

npm WARN @ionic-native/push@3.6.1 requires a peer of @ionic-native/core@^3.6.0 but none was installed.
npm WARN @ionic-native/push@3.6.1 requires a peer of @angular/core@* but none was installed.
npm WARN @ionic-native/push@3.6.1 requires a peer of rxjs@^5.0.1 but none was installed.
npm WARN mps-tester@1.1.1 No repository field.
npm WARN mps-tester@1.1.1 No license field.

Is there a reason it is done this way? Are my fears about dependencies unfounded?


#2

My ionic cli is installing ionic version 1 despite me having
Cordova CLI: 6.5.0
Ionic CLI Version: 2.1.8
Ionic App Lib Version: 2.1.4
ios-deploy version: 1.9.1
ios-sim version: 5.0.11
OS: macOS Sierra
Node Version: v7.9.0
Xcode version: Xcode 8.3.2 Build version 8E2002


#3

This is the version of the Ionic CLI running on your system (which is really outdated by the way, you should update to 2.2.3!).[quote=“robertcorey, post:1, topic:88098”]
This seems like it would be an issue
[/quote]

The package.json you posted is an even bigger problem - the project shouldn’t even work in any way in that state. Does it?

I suggest you update your CLI and generate a new project. package.json should look quite different.


#4

Thanks Sujan. It was defaulting to setting up an angular 1 project which bundled angular 1 with ionic 1 and installed via bower, when I passed it --v2 it worked correctly.


#5

Awesome.

Still, please upgrade your CLI or we will have you back with CLI caused errors in no time :wink: