Hello, I really tried to solve this problem by myself with google and other but it’s been 5h so I’m exhausted now xD

I have an app that connect to a wordpress site to display latest articles (it’s not live yet, it’s a work in progress). In the ionic lab, it works perfectly both Android and iOS. On real device, it’s work on Android too but on iOS, when the app launch it display an error “httpErrorResponse” and refuse to make any connection …

I did try to whiteliste, add my domain in the config xml, adding , … nothing made it work T_T

The NSAppTransportSecurity is configured too :







So why doesn’t it work ??? grrrr

Any help who be very appreciated !

I would suggest seeing if your problem persists even when using https endpoints and proper SSL certificates on the backend server, because you REALLY want that to be your deployment situation, so might as well get it sorted ASAP.

thanks for answer. The rest API is already secured, this is the url : . The certificat is properly installed (let’s encrypt).

That’s why I don’t understand what is wrong with my app ? It’s only on iOS (Xcode simulator + real device). When I run it with ionic serve, it’s work like it should (both iOS and Android).