How to disable text in splashscreen

Hello, I’m trying to remove the black text that appears in the upper left corner of the capacitor splash screen, but I have no idea where it comes from and how to disable it.


It only appears on my Android 12 OnePlus, on my Android 11 Xiaomi there’s no text.
I tried removing @capacitor/splash-screen, but the text is still there.
It also appears in the default ionic starter app.
Thank you for your help in advance.

I found a solution myself.
In android/app/src/main/res/values/styles.xml

Change

<style name="AppTheme.NoActionBarLaunch" parent="Theme.SplashScreen">
    <item name="android:background">@drawable/splash</item>
</style>

to

<style name="AppTheme.NoActionBarLaunch" parent="Theme.SplashScreen">
    <item name="android:background">@drawable/splash</item>
    <item name="android:windowNoTitle">true</item>
    <item name="android:windowFullscreen">true</item>
</style>

And the app name in the splashscreen disappears…
I have no idea why is this not in the docs.

1 Like

Hey, so that shouldn’t even be there to begin with. It might be from some customized settings inside the app.

I just tested this with a blank starter project and got the default capacitor launch image, so you might have some changes in there.

I created a brand new project and it was still there. Maybe it’s some “feature” of OnePlus’s launcher (OxygenOS)? But other native apps on this phone don’t have this text.

Anyways, the solution I provided above works perfectly in my case.

Still, it would be nice to know why this appeared. I can help by running tests on my phone if somebody is interested in tracing this down, can’t do it myself as I don’t have enough knowledge on this topic.

Yeah, it’s some bug on OnePlus, we got a report from a user having the same behavior and some users commented and all the people with the problem were using OnePlus devices. Doesn’t happen in other vendor devices.