How do I resolve these unment dependencies after 'ionic sass setup'?


#1

After issuing the ‘ionic sass setup’ command in the app folder, though the command was successful, I received a bunch of unment dependencies. This is the output;

zouti@cl0udz:~/dev-op/myApp$ ionic setup sass
npmnpm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/bower-registry-    client requires graceful-fs@'~2.0.0' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/graceful-fs,
npm WARN unmet dependency which is version 3.0.6
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/bower-registry-client requires lru-cache@'~2.3.0' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/lru-cache,
npm WARN unmet dependency which is version 2.5.0
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/bower-registry-client requires request@'~2.51.0' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/request,
npm WARN unmet dependency which is version 2.42.0
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/bower-registry-client requires mkdirp@'~0.3.5' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/mkdirp,
npm WARN unmet dependency which is version 0.5.0
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/decompress-zip/node_modules/touch requires nopt@'~1.0.10' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/decompress-zip/node_modules/nopt,
npm WARN unmet dependency which is version 2.2.1
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/insight/node_modules/configstore requires object-assign@'^2.0.0' but will load
npm WARN unmet dependency /home/zouti/dev-op/myApp/node_modules/bower/node_modules/insight/node_modules/object-assign,
npm WARN unmet dependency which is version 1.0.0

#2

@Zootee,
Hey!!
I have the same issue right now… How did you solve it?


#3

Try npm install -g gulp then subsequently issue ionic sass setup

If nothing still try:
(1) sudo npm update
(2) sudo npm install
(3) sudo ionic setup sass